ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jesse Stockall <je...@cryptocard.com>
Subject Re: jdk 1.3.1 and ant 1.3 compatability
Date Mon, 16 Jul 2001 22:55:50 GMT
On 16 Jul 2001 15:24:56 -0700, Tim Meals wrote:
> Jef --
> 
> I had a bunch of problems with JDK 1.3.1 under RedHat 7.0 Linux.  My research
> found a bunch of web pages, by both RedHat and Sun, saying to apply some patches
> or upgrade to RedHat 7.1.  I tried all the suggestions, but all that worked was
> turning off the HotSpot client VM.  Try it in the ant.sh script first:

I use Ant with 	1.3.0 IBM
		1.3.1 Blackdown
		1.3.1 Sun

On Debian with no issues

I also have to deal with RH 7.1 & there is a simple fix.
put this at the top of j2re1.3/bin/.java_wrapper 
"export LD_ASSUME_KERNEL=2.2.5"

Here is a little more info about the problem, Way to go RedHat!!

Note: Red Hat 7.1 enabled a floating point stack feature in the glibc
library that mucks up Java. Other distributions might follow their lead.
If your Java applications do not work, you can disable the floating
point stack by setting the LD_ASSUME_KERNEL environment variable to
2.2.5.


--
 Jesse Stockall			|	Tel: 1+ 613.599.2441 ext. 243
 CRYPTOCard Corporation		|	Fax: 1+ 613.599.2442	 	
 Suite 304, 300 March Rd.	|	email: jesse@cryptocard.com
 Ottawa, ON, Canada K2K 2E2	|	web: www.cryptocard.com 
---------------------------------------------------------------------
-------------- Debian - The Choice of a GNU Generation --------------


Mime
View raw message