ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cole, Andrew" <Andrew.C...@gs.com>
Subject Trouble Using JUnitReport
Date Tue, 10 Jul 2001 17:32:17 GMT
Hi,

I'm having trouble using the "report" nested element of the JUnitReport
task.  Initially I'd like to get this going without having to write my own
stylesheets, which the Javadoc seem to indicate should be possible, but I
get the following error:

XSL Error: Cannot use a DTMLiaison for a input DOM node... pass a
org.apache.xalan.xpath.xdom.XercesLiaison instead!
XSL Error: SAX Exception
org.apache.xalan.xslt.XSLProcessorException:
        at
org.apache.xalan.xslt.XSLTEngineImpl.error(XSLTEngineImpl.java:1720)
        at
org.apache.xalan.xslt.XSLTEngineImpl.error(XSLTEngineImpl.java:1612)
        at
org.apache.xalan.xslt.XSLTEngineImpl.getSourceTreeFromInput(XSLTEngineImpl.j
ava:844)
        at
org.apache.xalan.xslt.XSLTEngineImpl.process(XSLTEngineImpl.java:568)
        at
org.apache.tools.ant.taskdefs.optional.junit.AggregateTransformer.transform(
AggregateTransformer.java:460)
        at
org.apache.tools.ant.taskdefs.optional.junit.AggregateTransformer.createSing
lePageSummary(AggregateTransformer.java:266)
        at
org.apache.tools.ant.taskdefs.optional.junit.AggregateTransformer.transform(
AggregateTransformer.java:229)
        at
org.apache.tools.ant.taskdefs.optional.junit.XMLResultAggregator.execute(XML
ResultAggregator.java:169)
        at org.apache.tools.ant.Target.execute(Target.java:153)
        at org.apache.tools.ant.Project.runTarget(Project.java:898)
        at org.apache.tools.ant.Project.executeTarget(Project.java:536)
        at org.apache.tools.ant.Project.executeTargets(Project.java:510)
        at org.apache.tools.ant.Main.runBuild(Main.java:421)
        at org.apache.tools.ant.Main.main(Main.java:149)

My task is currently defined as:

  <target name="testreport">
    <junitreport>
      <fileset dir="${this.build.src}/${this.dir}" includes="**/TEST-*.xml"
/>
      <report format="noframes" />
    </junitreport>
  </target>


Any ideas on how to fix this ?

Thanks,

Andy

Mime
View raw message