ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Les Hughes <leslie.hug...@rubus.com>
Subject RE: Can't Get an Ant-generated EAR to open with J2EE reference ed ition Deploytool
Date Fri, 13 Jul 2001 10:21:30 GMT
Hi Marc,

I 'engineered'(alright stole) the Ear task from the War task for Weblogic
deployments. Ear is the same as war except for the different deployment
descriptors. In any case they both inherit down from zip so this could be
the root cause. The upshot of this is that you get zips defaults in your ear
(!) which could be causing a problem.

You could try turning compression off by setting the compress=false
attribute (wild guess).
You say that ear-ing the files doesn't work but winzipping does - points at
zip again but are you sure there are no differences in the archive?

Bye,

Les


> -----Original Message-----
> From: Marc Rabil [mailto:marc.rabil@simplica.com]
> Sent: 12 July 2001 01:17
> To: ant-user@jakarta.apache.org
> Subject: Can't Get an Ant-generated EAR to open with J2EE reference
> edition Deploytool
> 
> 
> I can't seem to get an ear file created with ANT (v1.1 or 
> 1.3) to open in
> the reference implementation deploytool (version 1.2.1).  I 
> am using Windows
> 2000 and have tried both JDK 1.3.0-C and 1.3.1.
> 
> I get a message window upon trying to open the ant-generated ear with
> File>Open Application in the deploytool GUI saying: 
> "myapp.ear does not
> appear to be a valid application archive".
> 
> Oddly enough, if I create an ear in the deploytool (which can 
> subsequently
> be opened without a problem), extract its contents and then 
> repackage those
> exact same files using ANT it still doesn't work.  If I just 
> use WinZip to
> zip up these same files and then rename the zip as an ear it 
> works fine!
> 
> Any help would be greatly appreciated.
> 
> Marc
> 

Mime
View raw message