ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Larry V. Streepy, Jr." <stre...@healthlanguage.com>
Subject path/fileset and missing directories
Date Fri, 06 Jul 2001 16:12:27 GMT
Ok, time for my stupid question of the week.  Since the email archives
are out of commission right now I don't feel too guilty... :-)

I'm trying to setup a path, which is referenced numerous times in the
remainder of the build file.  However, I want to use a nested fileset so
I can avoid listing the .zip files discretely (since they change
depending on the platform being built on).  Here's the snippet:

<!-- weblogic pieces of the path -->
<path id="wl.path">
  <pathelement location="${wl.home}/lib/weblogicaux.jar" />
  <pathelement location="${wl.home}/classes" />
  <pathelement location="${wl.cyberplus.dir}/mssqlserver4v70/classes" />
  <fileset dir="${wl.cyberplus.dir}/OracleJDBC/lib">
      <include name="**/*.zip"/>
  </fileset>
</path>

<property name="wl.path" refid="wl.path"/>


Ok, works just peachy, except on a cleanly installed box wherein the
mssqlserver and OracleJDBC directories do not yet exist. In that case,
the build fails when trying to create the fileset because the specified
"dir" does not exist.  Part of my build process will create these
directories (by extracting them from tar balls in the source tree), but
I can't get the build to even start in this initial state.

So, any ideas on how to get around this problem?

TIA.
-- 
Larry V. Streepy, Jr.
Chief Technical Officer and VP of Engineering

Health Language, Inc.  -- "We speak the language of healthcare"

970/626-5028 (office)           mailto:streepy@healthlanguage.com
970/626-4425 (fax)              http://www.healthlanguage.com

Mime
View raw message