ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Davison <pdavi...@channelwave.com>
Subject Re: jdk 1.3.1 and ant 1.3 compatability
Date Tue, 17 Jul 2001 01:53:14 GMT
There is an incompatibility between Sun's JDK 1.3.x and RedHat Linux 7.1.

Your segmentation fault is not related to ant but to running java under 
RH 7.1.  I found a thread on the Sun site concerning this and the following
patch (which worked for me).

There is a missing link (from the java executable's point of view) in RedHat
Linux 7.1.  To fix it do the following as root:

cd /lib/i686 
ln -s libpthread.so.0 libpthread.so
/sbin/ldconfig

This should allow you to run the hotspot VM. No need for 
-classic 
or 
export LD_ASSUME_KERNEL=2.2.5

Regards,
Pete.

Thus spake Eric Richardson <eric@milagrosoft.com> on Mon, 16 Jul 2001 18:40:53 -0700:

ER> Jesse Stockall wrote:
ER> > 
ER> > On 16 Jul 2001 15:24:56 -0700, Tim Meals wrote:
ER> > > Jef --
ER> > >
ER> > > I had a bunch of problems with JDK 1.3.1 under RedHat 7.0 Linux.  My research
ER> > > found a bunch of web pages, by both RedHat and Sun, saying to apply some
patches
ER> > > or upgrade to RedHat 7.1.  I tried all the suggestions, but all that worked
was
ER> > > turning off the HotSpot client VM.  Try it in the ant.sh script first:
ER> > 
ER> > I use Ant with  1.3.0 IBM
ER> >                 1.3.1 Blackdown
ER> >                 1.3.1 Sun
ER> > 
ER> > On Debian with no issues
ER> I've had no problem on Debian Potato with blackdown (1.3 and now 1.3.1)
ER> thanks to apt. 
ER> 
ER> How does the IBM VM compare as far as performance, memory etc?
ER> 
ER> Eric

Mime
View raw message