ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: OS/390, Ant 1.3 and Compiler Messages
Date Thu, 05 Jul 2001 23:46:43 GMT
On Fri,  6 Jul 2001 05:28, Myron Uecker wrote:
> I'm using Ant 1.3 to build code with JDK 1.1.8 and OS/390.  When javac
> runs, it prints out messages for everything except the compiler output.  In
> the output below, I'm building a simple class (15 lines) that has an
> intentional error.  As you can see, I'm getting messages from javac that
> I'm compiling one file, but there's no output from the compiler.  If I run
> javac outside of Ant, I get the error messages.  I have tried using
> -verbose and -debug settings and I see every message except the compiler
> messages.  It appears that either the messages are not being written to the
> output stream or the output stream is never being closed.
>
> I tried the same command on my Windows 2000 workstation and I did get
> compiler messages, so it has something to do with Ant running with IBM's
> JDK under OS/390.


If you look below you will see two error messages. Namely

> IOException getting canonical path for
> /usr/lpp/WebSphere/AppServer/lib/jsdk.jar
>
> : bad path error
>
> IOException getting canonical path for
> /usr/lpp/WebSphere/AppServer/lib/ibmwebas
> .jar: bad path error

This implies that the javac tool is never run as there is a problem setting 
up ClassPath for these entries. Does 
/usr/lpp/WebSphere/AppServer/lib/jsdk.jar exist and is it readable? Is there 
any other reason why java wouldn't be able to access that file?

Cheers,

Pete

*-----------------------------------------------------*
| "Faced with the choice between changing one's mind, |
| and proving that there is no need to do so - almost |
| everyone gets busy on the proof."                   |
|              - John Kenneth Galbraith               |
*-----------------------------------------------------*

Mime
View raw message