ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohit Peyyeti" <>
Subject Help with execon and mysql
Date Mon, 09 Jul 2001 04:57:30 GMT

Has anyone tried using at with mysql? I have a directory in 
which all the .sql files are stored. I want Ant using <sql>
or <execon> to run all of those .sql files in a directory.

I tried using <execon>, but looks like it does not work. 
This is part of the build file:

 <execon executable="mysql">
   <arg value="-u"/>
   <arg value="rtest"/>
   <arg value="-h"/>
   <arg value="helix"/>
   <arg value="-P"/>
   <arg value="3306"/>
   <arg value="-prtest"/>
   <arg value="-D"/>
   <arg value="rtest"/>
   <arg value="&lt;"/>
     <fileset dir="/var/www/${virtualhost}/data" includes="*.sql"/>

When I run ant with debug option, this is what I get to see:
[execon] Myos = Linux
[execon] mysql -u rtest -h helix -P 3306 -prtest -D rtest <
[execon] Executing mysql -u rtest -h helix -P 3306 -prtest -D rtest < /var/www/test/data/slogicdatadump.sql

Technically speaking, this is right. When I run the above statement from the command line,
this is
what I get:
ERROR 1045: Access denied for user: 'rtest@helix' (Using password: YES)

Whereas, when I run through Ant, it shows me mysql help. Some thing like mysql --help.

Any pointers?


TransLogic Systems
5th Floor, Amogh Plaza, Greenlands,
Hyderabad, AP - 500 016, INDIA
Ph: 91.40.3401795, Fax: 91.40.3407943

View raw message