ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Knights" <br...@knightsofthenet.com>
Subject RE: Problems with XSLT
Date Thu, 12 Jul 2001 01:10:37 GMT
It looks like you have something setting the SAXParserFactory system property.
If there wasn't one Saxon would be using its AElfred sax parser and that is an XMLReader (i.e.
it is a SAX2 parser)

 I am using Saxon 6.3 and have the jaxp 1.1 files (jaxp.jar, crimson.jar) from Sun in my classpath.
I removed the jaxp.jar and
parser.jar files that are by default installed in the ant/lib directory.

hth


> -----Original Message-----
> From: Kyle Adams [mailto:kadams@gfs.com]
> Sent: Wednesday, July 11, 2001 12:11 PM
> To: ant-user@jakarta.apache.org
> Subject: Problems with XSLT
>
>
> I'm beginning to play around with XSLT, and I've running into
> an odd error message. I'm using Saxon as my XSL parser; my
> classpath includes saxon.jar.  This is the style task being
> performed when I get the error:
>
>         <style basedir="."
> 	   destdir="."
> 	   style="style/build.xsl"
> 	   in="myProject.xml"
> 	   out="buildMyProject.xml" />
>
> This is the error message:
>
> java.lang.NoSuchMethodError: javax.xml.parsers.SAXParser: method
> getXMLReader()Lorg/xml/sax/XMLReader; not found
>                           ^----------------------------^
>
> I'm especially puzzled by the section highlighted above.
> Anyone know what's going one?
>
> Kyle
>
>
>
>
>


Mime
View raw message