ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill.J.Fell...@mail.sprint.com
Subject RE: tsamp is messed up : seemingly
Date Wed, 20 Jun 2001 19:09:51 GMT
Ummmm mm is double digit minutes
MM is double digit month

Check this thread for more info
http://marc.theaimsgroup.com/?l=ant-user&m=99049317906409&w=2


-----Original Message-----
From: viraj.purang [mailto:viraj_purang@spincircuit.com]
Sent: Wednesday, June 20, 2001 2:02 PM
To: ant-user
Subject: tsamp is messed up : seemingly


Hi,
  I get a weird error when I am using the following statements. 
___________________________________________
<target name="build-tstamp">
    <tstamp>
        <format property="TODAY" pattern="mmddyyyy"/>
    </tstamp>
  <echo message="The value of TODAY is : ${TODAY}"/>
</target>
  ___________________________________________
The date is field is OK but the month field keeps getting all junk 
values,
let me see if it mnakes difference if it is initialized  to 0 in 
properties.
I need to use this for tagging my code while I check it out.
_____________________________________________
Total time: 1 second
C:\CVS1\builder>ant build-tstamp
Buildfile: build.xml
build-tstamp:
     [echo] The value of TODAY is : 24202001
BUILD SUCCESSFUL

Total time: 1 second
C:\CVS1\builder>ant build-tstamp
Buildfile: build.xml
build-tstamp:
     [echo] The value of TODAY is : 25202001
BUILD SUCCESSFUL
Total time: 1 second1
__________________________________________

Regards,
Viraj Purang

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message