ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neville Burnell <Neville.Burn...@bmsoft.com.au>
Subject RE: Ant Problems, Win 2000
Date Fri, 08 Jun 2001 06:07:44 GMT
perhaps the JVM running ANT is also locking the JAR

-----Original Message-----
From: Jamie Tsao [mailto:jtsao@atinera.com]
Sent: Friday, 8 June 2001 10:38 AM
To: ant-user@jakarta.apache.org
Subject: RE: Ant Problems, Win 2000


hmmmm ...

That jar IS in my classpath, but the "clean" target I'm running doesn't
call javac or anything else that would use the classpath.  Besides, I
waited for hours (while doing other stuff, of course !!), and tried
running the "clean" target again, and I still get the same problem.  The
weblogic server is not running.  NOTHING is using that jar.  So I really
don't get it ...

help ..... ( i really don't want to manual delete that jar from explorer
everytime )

- Jamie

-----Original Message-----
From: Peter Donald [mailto:donaldp@apache.org]
Sent: Thursday, June 07, 2001 5:42 PM
To: ant-user@jakarta.apache.org
Subject: RE: Ant Problems, Win 2000


This is fairly common. Is there anywhere in ant file that you *use* the
jar
? (ie in <classpath> of a java task or like). If so it is likely that
this
task is locking the jar. SO when you try to delete it, it fails but as
soon
as ant finishes, the jar is unlocked. Thus in the second pass you can
delete the jar (or can delete it from explorer interface).

At 04:01 PM 6/7/01 -0700, Ryan Thompson wrote:
>I had the same problem, and if I ran the clean target twice, it would
work
>on the second attempt.
>
>-----Original Message-----
>From: Jamie Tsao [mailto:jtsao@atinera.com]
>Sent: Thursday, June 07, 2001 3:47 PM
>To: ant-user@jakarta.apache.org
>Subject: RE: Ant Problems, Win 2000
>
>
>Thanks for the replies so far ...
>
>I want to also add that only ANT is having a problem deleting this jar.
>If I go to that file through explorer, I CAN delete it manually.
>Therefore, I don't think it's a locking issue.  I'm worried that it's
>some bug having to do with the recursive deletion.
>
>More ideas ?
>
>- Jamie
>
>-----Original Message-----
>From: Will Hartung [mailto:willh@msoft.com]
>Sent: Thursday, June 07, 2001 3:46 PM
>To: ant-user@jakarta.apache.org
>Subject: Re: Ant Problems, Win 2000
>
>
>One thing that may (possibly) be locking those files is either Fast
Find
>from MSOffice, or the Indexing system that's part of the Search...
>functionality off of the Start menu.
>
>The Indexing system likes to grab new directories and lock them while
it
>is
>scanning and updating its index.
>
>Look for Indexing Service in your Search dialog.
>
>Best Regards,
>
>Will Hartung
>(willh@msoft.com)
>
>
>----- Original Message -----
>From: "Jamie Tsao" <jtsao@atinera.com>
>To: <ant-user@jakarta.apache.org>
>Sent: Thursday, June 07, 2001 2:55 PM
>Subject: RE: Ant Problems, Win 2000
>
>
>That's what I figured originally, so I basically just tried running my
>"prepare" target first, which only copies files over, then I run the
>"clean" target, which deletes those files.  No process could possible
be
>using those files at that point, but I still get the errors.
>
>Ideas ?  Possible bug ?
>
>- Jamie
>
>-----Original Message-----
>From: Jesse Tilly [mailto:JTilly@hoteltools.com]
>Sent: Thursday, June 07, 2001 2:50 PM
>To: 'ant-user@jakarta.apache.org'
>Subject: RE: Ant Problems, Win 2000
>
>
>If the files are being used by another process, Win2k, by default puts
a
>lock on these files.  Hence, you will receive an error on delete.
>
>MrT
>
>> -----Original Message-----
>> From: Jamie Tsao [mailto:jtsao@atinera.com]
>> Sent: Thursday, June 07, 2001 5:27 PM
>> To: ant-user@jakarta.apache.org
>> Subject: Ant Problems, Win 2000
>>
>>
>> Hi,
>> I've used Ant before on a Solaris, and found it to be quite a
>> reliable,
>> stable build tool.  I'm currently using it on a Win 2K platform, and
>> have run into some strange bugs.
>> Bug 1:
>> For some reason, the delete task doesn't behave properly
>> sometimes.  For
>> my "clean" target, I'm deleting the an entire directory.
>> That directory
>> contains .class files, config files, jar files, etc.  Certain
>> jar files
>> cannot be deleted for some reason.  I get the error message:
>>  [delete]:  Cannot delete ......
>> When I renamed the file to sometime else, it was fine.  There seems
to
>> be a bunch of inconsistencies because today I renamed the file to the
>> original name, and it worked.  1 hour later, it didn't work again !!
>> Anyone know why ?
>>
>> Bug 2:
>> There's one particular jar that I'm copying over to the deployment
>> directory that is causing weird warnings.  For some reason,
>> when use the
>> copy task to copy the jar to the deployment directory, the "modified"
>> timestamp on the jar is changed to the current time.  The Ant gives
me
>> some warning about future modified files. Anyone ?
>>
>> Thanks,
>> - Jamie
>>
>
>
>Attachment Converted: "g:\applications\eudora\attach\RE Ant Problems,
Win
2000"
>
Cheers,

Pete

*-----------------------------------------------------*
| "Faced with the choice between changing one's mind, |
| and proving that there is no need to do so - almost |
| everyone gets busy on the proof."                   |
|              - John Kenneth Galbraith               |
*-----------------------------------------------------*

Mime
View raw message