ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Murdoch" <adammurdoch...@yahoo.com>
Subject RE: "jar"/zip problem
Date Thu, 21 Jun 2001 12:29:51 GMT

Don't know if this is the problem, but building the Jar file into the same
directory you're trying to jar up might cause you some grief.  Particularly
when it starts working.

> -----Original Message-----
> From: J. Michael Caine [mailto:jmcaine@alum.rpi.edu]
> Sent: Thursday, 21 June 2001 9:06 AM
> To: ant-user@jakarta.apache.org
> Subject: "jar"/zip problem
>
>
> i was running 1.2-1 (the only version for which i found a Debian package).
> compilations and such seemed to work fine, but the "jar" task was failing,
> giving me:
>
> "Problem creating jar: ZIP file must have at least one entry"
> at java.util.zip.ZipOutputStream.finish(ZipOutputStream.java:294)
> <rest of stack trace>
>
> so i just installed 1.3, the latest binaries, and pointed to that.  again,
> it worked fine, except for the "jar" task.  so i suspect there's something
> wrong with my syntax, but it sure looks a lot like the example code.  i
> have:
>
> <target name="dist" depends="compile">
> 	<jar jarfile="${basedir}/build/it.jar" basedir="${basedir}/build"/>
> </target>
>
> could it be a problem with my java?  i have J2SDK 1.3.0-2.
>
> oh, of course, there are .class files (only) in ${basedir}/build/.  i
> checked that.


_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com


Mime
View raw message