ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frederick Lefebvre <flefeb...@recruitsoft.com>
Subject RE: More issues with Ant and Starteam
Date Tue, 05 Jun 2001 14:30:47 GMT
Hi Patrick,
 
        I do not have any answer to your questions but I have a few
questions...
        We are also using Starteam here and I managed last week to get ant
accepted as the standart way to precompile, compile and deploy our
application(in java).  I did not know there was a Starteam task... did you
write it yourself?   Can you point me to a reference on this?
 
        As for your problem with double quotes, did you try using single
quotes like this :
<arg line=' co -p
\"${starteam.username}:${starteam.password}@${starteam.servername}:${startea
m.port}/${starteam.projname}/${starteam.viewname}/dev/DeploymentDescriptors\
" -fs'/>
 
Thank's
 
Frederick Lefebvre
email: flefebvre@recruitsoft.com
Software Developer - C2B Team
Recruitsoft(Canada) Inc.
http://www.recruitsoft.com <http://www.recruitsoft.com/>  

 

-----Original Message-----
From: O'Hara, Patrick [mailto:patrick.ohara@workscape.com]
Sent: Tuesday, June 05, 2001 10:03 AM
To: Ant User Mailing List (E-mail)
Subject: More issues with Ant and Starteam



Since I was unable to figure out the touch issue with the starteam task, I
have decided to abandon the task in favor of the command line interface.
Ant is complaining about the exec task below.

        <exec executable="stcmd" dir="${build.basedir}"> 
          <arg line=" co -p
\"${starteam.username}:${starteam.password}@${starteam.servername}:${startea
m.port}/${starteam.projname}/${starteam.viewname}/dev/DeploymentDescriptors\
" -fs"/>

        </exec> 

The error I get dose not make much sense: 

        C:\weblogic\CoventryDevelopment\build.xml:90: Whitespace required
before attributes. 

I have determined that the issue is the quotes within the command line.  I
have tried replacing the \" with the &quot; macro, but I got "Reference to
undefined entity".  I even tried using &quote; just in case.  I am wondering
if anyone has an example of a command line that has embedded quotes in it?
I am using ANT 1.3 on Win2K.

Patrick D O'Hara 
N17 W24222 Riverwood Dr, 
Suite 330 
Waukesha, WI 53188-1162 
(262)408-3849 
(262)408-3840 Fax 


Mime
View raw message