ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peterson, Lance" <lpeter...@verticore.com>
Subject RE: doing SourceSafe get
Date Fri, 08 Jun 2001 21:24:36 GMT
Yes, I've seen the same behavior.  Use <arg value="$$/Tke" />.  I think the
parser consumes the single $ whether or not it's being used in a property
reference.

-----Original Message-----
From: Vittoria, Felice [mailto:Felice_Vittoria@bmc.com]
Sent: Friday, June 08, 2001 3:13 PM
To: 'ant-user@jakarta.apache.org'
Subject: RE: doing SourceSafe get


Pinar (and everyone else),

I found out something interesting.   I have the following build.xml:

<target name="setworkfolder">
       <exec executable="D:\Program Files\Microsoft Visual
Studio\Common\VSS\win32\ss.exe">
          <arg value="workfold" />
          <arg value="$/Tke" />
          <arg value="D:\VSSTest" />
       </exec>
</target>

If I run: ant -debug

I will get:

Detected Java Version: 1.2
Detected OS: Windows NT
parsing buildfile U:\ant\build.xml with URI = file:U:/ant/build.xml
Project base dir set to: U:\ant

[snip]

setworkfolder:
     [exec] Myos = Windows NT
     [exec] "D:\Program Files\Microsoft Visual
Studio\Common\VSS\win32\ss.exe" workfold /Tke D:\VSST
est

[snip]

Anyway, what I wanted to point out is that $/Tke was not read correctly.  It
was read as /Tke but it should be $/Tke.  I think this is causing the hang
problem.   When I run

D:\Program Files\Microsoft Visual Studio\Common\VSS\win32\ss.exe workfold
/Tke D:\VSSTest

I get:

/Tke is not a valid switch, and will be ignored.
Continue anyway?(Y/N)n   

Felice


Mime
View raw message