ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peterson, Lance" <lpeter...@verticore.com>
Subject RE: doing SourceSafe get
Date Tue, 05 Jun 2001 22:38:16 GMT
SS.EXE should be in your local SourceSafe directory.  Try \program
files\microsoft visual studio\common\vss\win32 (or wherever you installed
visual studio).  Does it run from the command line?  You should be able to
run "ss dir", and it should print the contents of your current SourceSafe
directory.  If you can get this to work, it should be pretty easy to make
vssget work.

-----Original Message-----
From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
Sent: Tuesday, June 05, 2001 4:26 PM
To: ant-user@jakarta.apache.org
Subject: RE: doing SourceSafe get



I couldn't find ss.exe on the new server. So what I did was just to copy 
ss.exe from the other server to the one that I currently getting the code 
from. I set ssdir to my new database on the command line and ssdir attribute

of vssget to where ss.exe is on the new server.
I can't test it whether it's working or not because we all have user names 
for login that have "space" between the characters and we have no 
passwords...
So until i find out how to specify the space between the characters of the 
user name and using no password in login attribute of vssget could someone 
please tell me what i did for "ss.exe" would work or not.

thanks in a million...

>From: "Pinar Bicioglu" <pinarbici@hotmail.com>
>Reply-To: ant-user@jakarta.apache.org
>To: ant-user@jakarta.apache.org
>Subject: RE: doing SourceSafe get
>Date: Tue, 05 Jun 2001 21:27:30 -0000
>
>
>
>
>>From: "Vittoria, Felice" <Felice_Vittoria@bmc.com>
>>Reply-To: ant-user@jakarta.apache.org
>>To: "'ant-user@jakarta.apache.org'" <ant-user@jakarta.apache.org>
>>Subject: RE: doing SourceSafe get
>>Date: Tue, 5 Jun 2001 15:05:04 -0500
>>
>>Pinar,
>>
>>Regarding my first statement:
>>
>>Well ... I found out that you need to set the SSDIR env var to the
>>srcsafe.ini you want to open.   Here's what I found in VSS's help:
>>
>>"Setting the SSDIR environment variable tells VSS where to find the
>>SRCSAFE.INI file for the VSS server installation to which you want to
>>connect.  Do this by typing the following at the MS-DOS prompt:
>
>
>>set ssdir=\\server\share\vss
>>
>>Where \\server\share\vss is the folder where the srcsafe.ini file is
>>located."
>
>I am a little confused here. When I go to file->open SourceSafe database,
>in the windows that is open, the name of the database is shown Asset 
>Planner
>2 and its path is shown \\Cds-main\VssDb\AssetPlannerII.
>And i have srcsafe.ini file in both "\\Cds-main\VssDb\AssetPlannerII-Conf"
>and "\\Cds-main\VssDb\AssetPlannerII". But neither if them have worked ???
>error message
>
>D:\ap2\javasrc\server>ant getcode
>Buildfile: build.xml
>
>getcode:
>
>BUILD FAILED
>
>D:\ap2\javasrc\server\build.xml:67: java.io.IOException: CreateProcess:
>\\Cds-main\VssDb\A
>ssetPlannerII-Conf\ss Get "$/Asset Planner 2" -GLD:\ap2 -I- -R -W 
>"-Yttraub,
>ttraub"  erro
>r=2
>--- Nested Exception ---
>java.io.IOException: CreateProcess: \\Cds-main\VssDb\AssetPlannerII-Conf\ss
>Get "$/Asset P
>lanner 2" -GLD:\ap2 -I- -R -W "-Yttraub, ttraub"  error=2
>        at java.lang.Win32Process.create(Native Method)
>        at java.lang.Win32Process.<init>(Win32Process.java:64)
>        at java.lang.Runtime.execInternal(Native Method)
>        at java.lang.Runtime.exec(Runtime.java:272)
>        at
>org.apache.tools.ant.taskdefs.Execute$CommandLauncher.exec(Execute.java:435
)
>        at
>org.apache.tools.ant.taskdefs.Execute$CommandLauncherProxy.exec(Execute.jav
a:55
>0)
>        at
>org.apache.tools.ant.taskdefs.Execute$WinNTCommandLauncher.exec(Execute.jav
a:57
>5)
>        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:329)
>        at
>org.apache.tools.ant.taskdefs.optional.vss.MSVSS.run(MSVSS.java:160)
>        at
>org.apache.tools.ant.taskdefs.optional.vss.MSVSSGET.execute(MSVSSGET.java:1
68)
>        at org.apache.tools.ant.Target.execute(Target.java, Compiled Code)
>        at org.apache.tools.ant.Project.runTarget(Project.java:898)
>        at org.apache.tools.ant.Project.executeTarget(Project.java, 
>Compiled
>Code)
>        at org.apache.tools.ant.Project.executeTargets(Project.java,
>Compiled Code)
>        at org.apache.tools.ant.Main.runBuild(Main.java, Compiled Code)
>        at org.apache.tools.ant.Main.main(Main.java:149)
>
>Total time: 6 seconds
>
>I remember getting this message before but i can't remember what i did to
>get rid of it :(
>
>>As far as my second:
>>
>>What I meant was to open a command-line window and, assuming you have
>>ss.exe
>>in your path, extract the source code running ss get.   You can see VSS's
>>help for running ss get.   What I was trying to get at here was to not run
>>ant's vssget but just plain ss get to extract source code.
>
>I have ss.exe in d:\Program Files\MicrosoftVisualStudio\VSS\win32
>
>I think it's working right. when I perform ss get from the command line it
>asks for username and pasword, but it couldn; tfind my username and 
>password
>i think it's been changed recently :)
>
>>
>>HTH,
>>Felice
>>
>>
>>
>>-----Original Message-----
>>From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>>Sent: Tuesday, June 05, 2001 2:56 PM
>>To: ant-user@jakarta.apache.org
>>Subject: RE: doing SourceSafe get
>>
>>
>>
>>
>>
>> >From: "Vittoria, Felice" <Felice_Vittoria@bmc.com>
>> >Reply-To: ant-user@jakarta.apache.org
>> >To: "'ant-user@jakarta.apache.org'" <ant-user@jakarta.apache.org>
>> >Subject: RE: doing SourceSafe get
>> >Date: Tue, 5 Jun 2001 14:44:13 -0500
>> >
>> >Hmm .. I guess what I meant was the database on a different server?  If
>> >it's
>> >on a different server then you may need to make additional configuration
>> >changes to your PC before running ant.
>>
>>Oh I am sorry about that. yes you're right it is on a different server!
>>What kind of configurations do i need to make. Is there any documentation
>>on
>>
>>that that i can use ??
>> >
>> >Also, if you perform the ss get command from the command-line, will it
>> >produce the same error as ant or will it work correctly?
>>
>>I don't think that I understand what you mean. the error message Iposted 
>>in
>>my earlier message gets generated when I write "ant getcode" in a command
>>line.
>>
>> >
>> >-----Original Message-----
>> >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> >Sent: Tuesday, June 05, 2001 2:39 PM
>> >To: ant-user@jakarta.apache.org
>> >Subject: RE: doing SourceSafe get
>> >
>> >
>> >
>> >It is actually both. It is different database and differen project.
>> >
>> >the database was APJUL2000 and the project's name was $/AP2.0{struts}
>> >before
>> >
>> >with the code below.
>> >
>> ><target name="getcode">
>> >       <vssget vsspath="$/AP2.0(struts)"
>> >          login="ttraub, ttraub"
>> >          writable="true"
>> >          localpath="D:/ap20"
>> >          recursive="true"
>> >          ssdir="D:/Program Files/Microsoft Visual Studio/VSS/win32" />
>> >   </target>
>> >
>> >Now the database is Asset Planner 2 and the project's name is the same
>> >which
>> >
>> >is $/Asset Planner 2 with the following code.
>> >
>> ><target name="getcode">
>> >       <vssget vsspath="$/Asset Planner 2"
>> >          login="ttraub, ttraub"
>> >          writable="true"
>> >          localpath="D:/ap2"
>> >          recursive="true"
>> >          ssdir="D:/Program Files/Microsoft Visual Studio/VSS/win32" />
>> >   </target>
>> >
>> >
>> >
>> > >From: "Vittoria, Felice" <Felice_Vittoria@bmc.com>
>> > >Reply-To: ant-user@jakarta.apache.org
>> > >To: "'ant-user@jakarta.apache.org'" <ant-user@jakarta.apache.org>
>> > >Subject: RE: doing  SourceSafe get
>> > >Date: Tue, 5 Jun 2001 14:15:18 -0500
>> > >
>> > >Are you getting the code from a different database or a "project"
>>within
>> > >that database?   Also, what values did you change?
>> > >
>> > >-----Original Message-----
>> > >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > >Sent: Tuesday, June 05, 2001 2:06 PM
>> > >To: ant-user@jakarta.apache.org
>> > >Subject: doing SourceSafe get
>> > >
>> > >
>> > >I worked with "vssget" task before and it was working. this time I had
>>to
>> > >get the code from a different database. And somehow it's not working. 
>>I
>> > >don't understand what makes the difference.
>> > >I have the code as below
>> > >
>> > ><target name="getcode">
>> > >       <vssget vsspath="$/Asset Planner 2"
>> > >          login="pinarb, pinarb"
>> > >          writable="true"
>> > >          localpath="D:/ap2"
>> > >          recursive="true"
>> > >          ssdir="D:/Program Files/Microsoft Visual Studio/VSS/win32" 
>>/>
>> > >   </target>
>> > >
>> > >it generates an error message like this...
>> > >
>> > >D:\ap2\javasrc\server>ant getcode
>> > >Buildfile: build.xml
>> > >
>> > >getcode:
>> > >    [vssget] $/Asset Planner 2 is not an existing filename or project
>> > >
>> > >BUILD FAILED
>> > >
>> > >D:\ap2\javasrc\server\build.xml:66: Failed executing: "D:\Program
>> > >Files\Microsoft Visual S
>> > >tudio\VSS\win32\ss" Get "$/Asset Planner 2" -GLD:\ap2 -I- -R -W
>> >"-Yttraub,
>> > >ttraub"
>> > >
>> > >Total time: 3 seconds
>> > >
>> > >is it about changin the mode of the file. Actually I even tried this
>>but
>> >it
>> > >didn't work
>> > >_________________________________________________________________
>> > >Get your FREE download of MSN Explorer at http://explorer.msn.com
>> >
>> >_________________________________________________________________
>> >Get your FREE download of MSN Explorer at http://explorer.msn.com
>>
>>_________________________________________________________________
>>Get your FREE download of MSN Explorer at http://explorer.msn.com
>
>_________________________________________________________________
>Get your FREE download of MSN Explorer at http://explorer.msn.com
>

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com

Mime
View raw message