ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vittoria, Felice" <Felice_Vitto...@bmc.com>
Subject RE: VSSGET label attribute
Date Tue, 19 Jun 2001 19:48:14 GMT
Ming,

I got it to work on my machine by changing the vsspath to "$/Project" where
Project=a valid project in my repository.    So, I guess you would have to
change vsspath to:
$/CLE/test/JAR SOURCE/LEGALEDCENTER

Try that.

Felice

-----Original Message-----
From: Tan, Ming [mailto:Ming.Tan@westgroup.com]
Sent: Tuesday, June 19, 2001 2:33 PM
To: 'ant-user@jakarta.apache.org'
Subject: RE: VSSGET label attribute


Thanks Felice.

Here's my code:

 <target name="sourcesafeJava">
    <echo message="Getting java files from VSS" />
      
    <vssget localPath="${Java_Source_Files}"
    	recursive="true" 
    	label="testLabel"
      login="xxx,yyy"
      vsspath="\CLE\test\JAR SOURCE\LEGALEDCENTER"
      writable="true"
      ssdir="the location of my ss.exe"/>
  </target>
  
I keep getting "version not found" error...it will only work if I label all
the folders. One more thing, I have used the same code (different values for
the attributes) to access another VSS database. So, may be there is some
setup work in VSS that I have to do?

-Ming 

-----Original Message-----
From: Vittoria, Felice [mailto:Felice_Vittoria@bmc.com]
Sent: Tuesday, June 19, 2001 2:18 PM
To: 'ant-user@jakarta.apache.org'
Subject: RE: VSSGET label attribute


Ming,

You shouldn't have to label all folders within the project ... just the
parent folder.  Would it be possible to post your code up again?   I somehow
missed it.   

Felice

-----Original Message-----
From: Tan, Ming [mailto:Ming.Tan@westgroup.com]
Sent: Tuesday, June 19, 2001 1:58 PM
To: 'ant-user@jakarta.apache.org'
Subject: VSSGET label attribute


Hi, all:

May be there is something I don't understand, in order for VSSGET to work
(using label), Do I have to label all the folders for all levels in my VSS
project? I have tried to just label the parent folder and it didn't work. Is
there anything in VSS that I should know/do?

Thanks in advance.

-Ming

-----Original Message-----
From: Nico Seessle [mailto:nico@apache.org]
Sent: Tuesday, June 19, 2001 12:51 PM
To: ant-user@jakarta.apache.org
Subject: Re: VSSGET label attribute


----- Original Message -----
From: "Tan, Ming" <Ming.Tan@westgroup.com>
To: <ant-user@jakarta.apache.org>
Sent: Tuesday, June 19, 2001 4:28 PM
Subject: RE: VSSGET label attribute


> Hi, Nico:
>
> It worked only after I took out the "-VL" from the label "-VLRelease 1.3 -
> QA 002". What is "-VL", are they supposed to be there?
>

Copied from the Online Help:
---
-V Get an old file or project version

"-VLFinal Beta" Displays the version with the label Final Beta.
---

Are you sure there exists a Label "Release 1.3 - QA 002" in VSS? I can
reproduce your problem if I try to get a Label which does not exist.

Nico

Mime
View raw message