ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vittoria, Felice" <Felice_Vitto...@bmc.com>
Subject RE: doing SourceSafe get
Date Fri, 08 Jun 2001 20:08:43 GMT
Ok ... what's the script again?

-----Original Message-----
From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
Sent: Friday, June 08, 2001 3:04 PM
To: ant-user@jakarta.apache.org
Subject: RE: doing SourceSafe get



oopps .. I'd written $AssetPlanner 2 instead of $/AssetPlanner 2. Now it's 
getting the code. But it's not working when I use the script to get the code

>From: "Pinar Bicioglu" <pinarbici@hotmail.com>
>Reply-To: ant-user@jakarta.apache.org
>To: ant-user@jakarta.apache.org
>Subject: RE: doing SourceSafe get
>Date: Fri, 08 Jun 2001 19:55:19 -0000
>
>the output i get is,
>
>D:\Program Files\Microsoft Visual Studio\VSS\win32>ss get "$Asset Planner 
>2"
>-R
>-Yant, ant
>Username: ant
>Password: ant
>$Asset Planner 2 is not an existing filename or project
>ant is not an existing filename or project
>
>but it's an existing file ??? :(
>>From: "Vittoria, Felice" <Felice_Vittoria@bmc.com>
>>Reply-To: ant-user@jakarta.apache.org
>>To: "'ant-user@jakarta.apache.org'" <ant-user@jakarta.apache.org>
>>Subject: RE: doing SourceSafe get
>>Date: Fri, 8 Jun 2001 14:48:08 -0500
>>
>>Actually, what I was looking for is the command that you entered on the
>>command-line.   That is, assuming you did the following:
>>
>>cd D:\Program Files\Microsoft Visual Studio\VSS\win32
>>D:\Program Files\Microsoft Visual Studio\VSS\win32>ss get "$/Asset Planner
>>2" -R -I-Y -GWS -Yant,ant
>>
>>what did you get as output?  Note: ensure that the user has access to the
>>repository.
>>
>>Felice
>>
>>-----Original Message-----
>>From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>>Sent: Friday, June 08, 2001 2:41 PM
>>To: ant-user@jakarta.apache.org
>>Subject: RE: doing SourceSafe get
>>
>>
>>here is the code I have;
>>
>><target name="getcode">
>>      <exec executable="D:\Program Files\Microsoft Visual
>>Studio\VSS\win32\ss.exe">
>>   <arg value="get" />
>>   <arg value="$/Asset Planner 2" />
>>   <arg value="-R" />
>>   <arg value="-I" />
>>   <arg value="-GWS" />
>>   <arg value="-Yant,ant"/>
>></exec>
>>   </target>
>>
>>and here is the code it generates
>>
>>D:\ap2\javasrc\server>ant getcode
>>Buildfile: build.xml
>>
>>getcode:
>>and it just hang there...
>>
>> >From: "Vittoria, Felice" <Felice_Vittoria@bmc.com>
>> >Reply-To: ant-user@jakarta.apache.org
>> >To: "'ant-user@jakarta.apache.org'" <ant-user@jakarta.apache.org>
>> >Subject: RE: doing SourceSafe get
>> >Date: Fri, 8 Jun 2001 14:24:01 -0500
>> >
>> >Ok ... can you supply the command that you are trying to run
>> >
>> >Thanks.
>> >
>> >-----Original Message-----
>> >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> >Sent: Friday, June 08, 2001 2:15 PM
>> >To: ant-user@jakarta.apache.org
>> >Subject: RE: doing SourceSafe get
>> >
>> >
>> >
>> >
>> >Felice,
>> >I am using diffrent username that is on the server already. It accepts
>>that
>> >but still says "unrecognizable command : -I-Y"
>> >
>> >and my ssdir is set to where my rpoject is on the server
>> >
>> > >From: "Vittoria, Felice" <Felice_Vittoria@bmc.com>
>> > >Reply-To: ant-user@jakarta.apache.org
>> > >To: "'ant-user@jakarta.apache.org'" <ant-user@jakarta.apache.org>
>> > >Subject: RE: doing SourceSafe get
>> > >Date: Fri, 8 Jun 2001 14:02:43 -0500
>> > >
>> > >Pinar,
>> > >
>> > >Add your username (pbicioglu) to the database you are trying to 
>>connect
>> >to
>> > >and then try the command-line thing again.  Oh .. make sure your
>>username
>> > >has access to the server.    Do you have the SSDIR env var set?
>> > >
>> > >As far as I-Y ... it should be -I-Y.
>> > >
>> > >Felice
>> > >
>> > >-----Original Message-----
>> > >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > >Sent: Friday, June 08, 2001 1:42 PM
>> > >To: ant-user@jakarta.apache.org
>> > >Subject: RE: doing SourceSafe get
>> > >
>> > >
>> > >
>> > >when I run ss.exe from the command line with the same options it 
>>prints
>> >out
>> > >"username=pbicioglu(my NT username) and asks for the password. Since 
>>my
>> > >username is different for the access on the server I skipped the
>>password
>> > >part (then it prints "user name not found) and enter the appropriate
>> > >username and password it accepts that then says "unrecognized command
>>I-Y
>> > >Or
>> > >
>> > >I (i tried both).........
>> > >
>> > > >From: "Peterson, Lance" <lpeterson@verticore.com>
>> > > >Reply-To: ant-user@jakarta.apache.org
>> > > >To: "'ant-user@jakarta.apache.org'" <ant-user@jakarta.apache.org>
>> > > >Subject: RE: doing SourceSafe get
>> > > >Date: Fri, 8 Jun 2001 09:21:44 -0600
>> > > >
>> > > >Have you tried running SS.EXE from the command line with the same
>> > >options?
>> > > >What does it do?  This will tell you what's hanging in <exec>.
>> > > >
>> > > >-----Original Message-----
>> > > >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > > >Sent: Friday, June 08, 2001 9:00 AM
>> > > >To: ant-user@jakarta.apache.org
>> > > >Subject: RE: doing SourceSafe get
>> > > >
>> > > >
>> > > >
>> > > >thanks for your help Felice but it didn't make any difference ...:(
>> > > >I can't think of anything else to solve this problem!
>> > > >
>> > > > >From: "Vittoria, Felice" <Felice_Vittoria@bmc.com>
>> > > > >Reply-To: ant-user@jakarta.apache.org
>> > > > >To: "'ant-user@jakarta.apache.org'" <ant-user@jakarta.apache.org>
>> > > > >Subject: RE: doing SourceSafe get
>> > > > >Date: Fri, 8 Jun 2001 09:29:46 -0500
>> > > > >
>> > > > >Hmm ... maybe it's hanging because of the -I- argument.  I think
>>that
>> > >you
>> > > > >need to change it to either a -I-Y or -I-N.
>> > > > >
>> > > > >Here's the help page from VSS regarding this command-line option:
>> > > > >
>> > > > >-I Command-Line Option
>> > > > >There are a number of circumstances when VSS commands ask for 
>>input
>> > >from
>> > > > >the
>> > > > >user (for example, warnings containing Yes or No questions). This
>>is
>> > >not
>> > > > >desirable when writing scripts or macros that execute the VSS
>>command
>> > > >line
>> > > > >from inside other programs. Use the -I- option to ensure that VSS
>> >never
>> > > > >asks
>> > > > >for user input.
>> > > > >
>> > > > >When using the -I option, include the -C option to avoid the
>>comment
>> > > > >prompt.
>> > > > >
>> > > > >The following table lists ways to use the -I option.
>> > > > >
>> > > > >Option Description
>> > > > >-I-Y Instructs VSS to answer Yes to all Yes or No questions.
>> > > > >-I-N Instructs VSS to answer No to all Yes or No questions.
>> > > > >
>> > > > >HTH,
>> > > > >Felice
>> > > > >
>> > > > >-----Original Message-----
>> > > > >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > > > >Sent: Friday, June 08, 2001 9:22 AM
>> > > > >To: ant-user@jakarta.apache.org
>> > > > >Subject: RE: doing SourceSafe get
>> > > > >
>> > > > >
>> > > > >
>> > > > >i already tried this. It stil just hangs there...After waiting for
>>a
>> > > >while
>> > > > >I
>> > > > >
>> > > > >terminated the program by entering ctrl+C and here is the message 
>>I
>> >got
>> > > > >
>> > > > >D:\ap2\javasrc\server>ant getcode
>> > > > >Buildfile: build.xml
>> > > > >
>> > > > >getcode:
>> > > > >      [exec] Username: ant
>> > > > >^CTerminate batch job (Y/N)?
>> > > > >d:\jdk1.2.2\bin\java.exe was unexpected at this time.
>> > > > >
>> > > > >thanks for your help! :)
>> > > > >
>> > > > >
>> > > > > >From: Jeff Post <jeffp@genesyslab.com>
>> > > > > >Reply-To: ant-user@jakarta.apache.org
>> > > > > >To: "'ant-user@jakarta.apache.org'" 
>><ant-user@jakarta.apache.org>
>> > > > > >Subject: RE: doing SourceSafe get
>> > > > > >Date: Thu, 7 Jun 2001 13:51:43 -0700
>> > > > > >
>> > > > > >I think it is hanging because it is waiting for a password. Try
>> ><arg
>> > > > > >value="-Yant,ant" /> (remove the space) and see if that works.
>> > > > > >
>> > > > > >JP
>> > > > > >
>> > > > > >-----Original Message-----
>> > > > > >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > > > > >Sent: Thursday, June 07, 2001 1:17 PM
>> > > > > >To: ant-user@jakarta.apache.org
>> > > > > >Subject: RE: doing SourceSafe get
>> > > > > >
>> > > > > >
>> > > > > >
>> > > > > >in my earlier message I'd asked about "-Y"
>> > > > > >the user name and password I have is  "ant, ant"
>> > > > > >So when I write "<arg value="-Yant, ant" />, i get the following
>> > > > > >
>> > > > > >D:\ap2\javasrc\server>ant getcode
>> > > > > >Buildfile: build.xml
>> > > > > >
>> > > > > >getcode:
>> > > > > >      [exec] Username: ant
>> > > > > >
>> > > > > >then it just hangs there !!
>> > > > > >
>> > > > > > >From: Jeff Post <jeffp@genesyslab.com>
>> > > > > > >Reply-To: ant-user@jakarta.apache.org
>> > > > > > >To: "'ant-user@jakarta.apache.org'"
>><ant-user@jakarta.apache.org>
>> > > > > > >Subject: RE: doing SourceSafe get
>> > > > > > >Date: Thu, 7 Jun 2001 12:48:07 -0700
>> > > > > > >
>> > > > > > >You don't use "exec task with vssget". Instead of using the
>>task
>> > > > >vssget,
>> > > > > > >you
>> > > > > > >use the task exec.
>> > > > > > >
>> > > > > > >His example shows how to use that task:
>> > > > > > >
>> > > > > > >     Example:
>> > > > > > >
>> > > > > > >     <exec executable="${ss.path}/ss.exe">
>> > > > > > >        <arg value="get" />
>> > > > > > >        <arg value="${project}" />
>> > > > > > >        <arg value="-R" />
>> > > > > > >        <arg value="-I-" />
>> > > > > > >        <arg value="-GWS" />
>> > > > > > >        <arg value="-Y${ss.user},${ss.pass}" />
>> > > > > > >     </exec>
>> > > > > > >
>> > > > > > >JP
>> > > > > > >
>> > > > > > >-----Original Message-----
>> > > > > > >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > > > > > >Sent: Thursday, June 07, 2001 12:40 PM
>> > > > > > >To: ant-user@jakarta.apache.org
>> > > > > > >Subject: RE: doing SourceSafe get
>> > > > > > >
>> > > > > > >
>> > > > > > >
>> > > > > > >this helped a lot..I've got something to work on now. So it's
>>not
>> > > > >working
>> > > > > > >correcty.
>> > > > > > >What I don;t understand is how to use exec task with vssget. I
>> >mean
>> > > > >what
>> > > > > >is
>> > > > > > >the right way to execute vssget with "-GWS" option ??
>> > > > > > >Thanks
>> > > > > > >
>> > > > > > > >From: "Peterson, Lance" <lpeterson@verticore.com>
>> > > > > > > >Reply-To: ant-user@jakarta.apache.org
>> > > > > > > >To: "'ant-user@jakarta.apache.org'"
>> ><ant-user@jakarta.apache.org>
>> > > > > > > >Subject: RE: doing SourceSafe get
>> > > > > > > >Date: Thu, 7 Jun 2001 12:56:53 -0600
>> > > > > > > >
>> > > > > > > >SS.EXE has many command-line options.  For example, running
>>the
>> > > > >command
>> > > > > > >"ss
>> > > > > > > >get $/dev/project1/src -R -I-" instructs SourceSafe to
>> > >recursively
>> > > > >get
>> > > > > > >all
>> > > > > > > >files from the $/dev/project1/src project.  If you want to
>>make
>> > > >sure
>> > > > > > > >SourceSafe does not overwrite your checked-out files, you 
>>can
>> >add
>> > > >the
>> > > > > > >-GWS
>> > > > > > > >option.
>> > > > > > > >
>> > > > > > > ><vssget> does not support the -GWS option.  So therefore you
>> >can
>> > > >use
>> > > > > >the
>> > > > > > > ><exec> task to call SS.EXE directly and pass it the -GWS
>>option
>> > > >using
>> > > > > >the
>> > > > > > > ><arg> element.
>> > > > > > > >
>> > > > > > > >Example:
>> > > > > > > >
>> > > > > > > ><exec executable="${ss.path}/ss.exe">
>> > > > > > > >   <arg value="get" />
>> > > > > > > >   <arg value="${project}" />
>> > > > > > > >   <arg value="-R" />
>> > > > > > > >   <arg value="-I-" />
>> > > > > > > >   <arg value="-GWS" />
>> > > > > > > >   <arg value="-Y${ss.user},${ss.pass}" />
>> > > > > > > ></exec>
>> > > > > > > >
>> > > > > > > >where...
>> > > > > > > >
>> > > > > > > >${ss.path} is the path to SS.EXE (usually c:\program
>> > > >files\microsoft
>> > > > > > >visual
>> > > > > > > >studio\common\vss\win32).
>> > > > > > > >${project} is the project path (i.e. $/Dev/source).
>> > > > > > > >${ss.user} and ${ss.pass} are username and password.
>> > > > > > > >
>> > > > > > > >Hope this helps!
>> > > > > > > >
>> > > > > > > >-----Original Message-----
>> > > > > > > >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > > > > > > >Sent: Thursday, June 07, 2001 10:50 AM
>> > > > > > > >To: ant-user@jakarta.apache.org
>> > > > > > > >Subject: RE: doing SourceSafe get
>> > > > > > > >
>> > > > > > > >
>> > > > > > > >
>> > > > > > > >I checked the source safe and ant doc but couldn't come up
>>with
>> > > > > >anything
>> > > > > > > >useful :(
>> > > > > > > >So what I understand from this is that I can control which
>>file
>> > >to
>> > > > >get
>> > > > > > >form
>> > > > > > > >the sourcesafe when i perform "ant getcode" from the command
>> >line
>> > > > > > > >Is that correct ?
>> > > > > > > >
>> > > > > > > > >From: "Peterson, Lance" <lpeterson@verticore.com>
>> > > > > > > > >Reply-To: ant-user@jakarta.apache.org
>> > > > > > > > >To: "'ant-user@jakarta.apache.org'"
>> > ><ant-user@jakarta.apache.org>
>> > > > > > > > >Subject: RE: doing SourceSafe get
>> > > > > > > > >Date: Wed, 6 Jun 2001 15:10:26 -0600
>> > > > > > > > >
>> > > > > > > > >You can control overwrites by using the <exec> task to 
>>call
>> > > >SS.EXE
>> > > > > > > >directly
>> > > > > > > > >and passing the correct options (see the SourceSafe
>> > > >documentation).
>> > > > > > > > ><vssget> does not have this capability.
>> > > > > > > > >
>> > > > > > > > >-----Original Message-----
>> > > > > > > > >From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > > > > > > > >Sent: Wednesday, June 06, 2001 2:32 PM
>> > > > > > > > >To: ant-user@jakarta.apache.org
>> > > > > > > > >Subject: RE: doing SourceSafe get
>> > > > > > > > >
>> > > > > > > > >
>> > > > > > > > >
>> > > > > > > > >Here is another problem we found about "vssget" task 
>>....If
>> >you
>> > > > >have
>> > > > > > > > >checked
>> > > > > > > > >
>> > > > > > > > >out a file and changed it, vssget will overwrite your file
>> > > >without
>> > > > > > >asking
>> > > > > > > > >you. is there a way to say  "do not overwrite file if
>>checked
>> > > >out"
>> > > > >or
>> > > > > > >"do
>> > > > > > > > >not overwrite a file which is not read-only".
>> > > > > > > > >
>> > > > > > > > >Thanks
>> > > > > > > > >
>> > > > > > > > >
>> > > > > > > > >
>> > > > > > > > > >From: "Pinar Bicioglu" <pinarbici@hotmail.com>
>> > > > > > > > > >Reply-To: ant-user@jakarta.apache.org
>> > > > > > > > > >To: ant-user@jakarta.apache.org
>> > > > > > > > > >Subject: RE: doing SourceSafe get
>> > > > > > > > > >Date: Tue, 05 Jun 2001 22:48:55 -0000
>> > > > > > > > > >
>> > > > > > > > > >
>> > > > > > > > > >yes you're right it is in there. Actually i knew that it
>> >was
>> > > > >there.
>> > > > > > >but
>> > > > > > > > > >since I am using a server in Europe I thought there
>>should
>> >be
>> > > > > >another
>> > > > > > > >one
>> > > > > > > > > >on
>> > > > > > > > > >that server!!
>> > > > > > > > > >It seems like it is working now. The only thing that I
>>need
>> > >to
>> > > >be
>> > > > > > >done
>> > > > > > > > >with
>> > > > > > > > > >is that to write a login attribute without specifying a
>> > > >password
>> > > > >:)
>> > > > > > > > > >
>> > > > > > > > > >Or I can get a new user name and password collections,
>>but
>> > >the
>> > > > > >person
>> > > > > > > >who
>> > > > > > > > > >takes care of this stuff is in Europe and he probably is
>> > > >slepping
>> > > > > > >right
>> > > > > > > > >now
>> > > > > > > > > >because it's midnight over there :)
>> > > > > > > > > >
>> > > > > > > > > >i want to get over with vssget today before I leave :)
>> > > > > > > > > >
>> > > > > > > > > >Thanks a lot for your help :)
>> > > > > > > > > >
>> > > > > > > > > >>From: "Peterson, Lance" <lpeterson@verticore.com>
>> > > > > > > > > >>Reply-To: ant-user@jakarta.apache.org
>> > > > > > > > > >>To: "'ant-user@jakarta.apache.org'"
>> > > > ><ant-user@jakarta.apache.org>
>> > > > > > > > > >>Subject: RE: doing SourceSafe get
>> > > > > > > > > >>Date: Tue, 5 Jun 2001 16:38:16 -0600
>> > > > > > > > > >>
>> > > > > > > > > >>SS.EXE should be in your local SourceSafe directory.
>>Try
>> > > > >\program
>> > > > > > > > > >>files\microsoft visual studio\common\vss\win32 (or
>> >wherever
>> > > >you
>> > > > > > > > >installed
>> > > > > > > > > >>visual studio).  Does it run from the command line?  
>>You
>> > > >should
>> > > > >be
>> > > > > > > >able
>> > > > > > > > >to
>> > > > > > > > > >>run "ss dir", and it should print the contents of your
>> > >current
>> > > > > > > > >SourceSafe
>> > > > > > > > > >>directory.  If you can get this to work, it should be
>> >pretty
>> > > > >easy
>> > > > > >to
>> > > > > > > > >make
>> > > > > > > > > >>vssget work.
>> > > > > > > > > >>
>> > > > > > > > > >>-----Original Message-----
>> > > > > > > > > >>From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > > > > > > > > >>Sent: Tuesday, June 05, 2001 4:26 PM
>> > > > > > > > > >>To: ant-user@jakarta.apache.org
>> > > > > > > > > >>Subject: RE: doing SourceSafe get
>> > > > > > > > > >>
>> > > > > > > > > >>
>> > > > > > > > > >>
>> > > > > > > > > >>I couldn't find ss.exe on the new server. So what I did
>> >was
>> > > >just
>> > > > > >to
>> > > > > > > >copy
>> > > > > > > > > >>ss.exe from the other server to the one that I 
>>currently
>> > > >getting
>> > > > > >the
>> > > > > > > > >code
>> > > > > > > > > >>from. I set ssdir to my new database on the command 
>>line
>> >and
>> > > > >ssdir
>> > > > > > > > > >>attribute
>> > > > > > > > > >>
>> > > > > > > > > >>of vssget to where ss.exe is on the new server.
>> > > > > > > > > >>I can't test it whether it's working or not because we
>>all
>> > > >have
>> > > > > >user
>> > > > > > > > >names
>> > > > > > > > > >>for login that have "space" between the characters and
>>we
>> > >have
>> > > > >no
>> > > > > > > > > >>passwords...
>> > > > > > > > > >>So until i find out how to specify the space between 
>>the
>> > > > > >characters
>> > > > > > >of
>> > > > > > > > >the
>> > > > > > > > > >>user name and using no password in login attribute of
>> >vssget
>> > > > >could
>> > > > > > > > >someone
>> > > > > > > > > >>please tell me what i did for "ss.exe" would work or
>>not.
>> > > > > > > > > >>
>> > > > > > > > > >>thanks in a million...
>> > > > > > > > > >>
>> > > > > > > > > >> >From: "Pinar Bicioglu" <pinarbici@hotmail.com>
>> > > > > > > > > >> >Reply-To: ant-user@jakarta.apache.org
>> > > > > > > > > >> >To: ant-user@jakarta.apache.org
>> > > > > > > > > >> >Subject: RE: doing SourceSafe get
>> > > > > > > > > >> >Date: Tue, 05 Jun 2001 21:27:30 -0000
>> > > > > > > > > >> >
>> > > > > > > > > >> >
>> > > > > > > > > >> >
>> > > > > > > > > >> >
>> > > > > > > > > >> >>From: "Vittoria, Felice" <Felice_Vittoria@bmc.com>
>> > > > > > > > > >> >>Reply-To: ant-user@jakarta.apache.org
>> > > > > > > > > >> >>To: "'ant-user@jakarta.apache.org'"
>> > > > > ><ant-user@jakarta.apache.org>
>> > > > > > > > > >> >>Subject: RE: doing SourceSafe get
>> > > > > > > > > >> >>Date: Tue, 5 Jun 2001 15:05:04 -0500
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>Pinar,
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>Regarding my first statement:
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>Well ... I found out that you need to set the SSDIR
>>env
>> > >var
>> > > > >to
>> > > > > > >the
>> > > > > > > > > >> >>srcsafe.ini you want to open.   Here's what I found
>>in
>> > > >VSS's
>> > > > > > >help:
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>"Setting the SSDIR environment variable tells VSS
>>where
>> > >to
>> > > > >find
>> > > > > > >the
>> > > > > > > > > >> >>SRCSAFE.INI file for the VSS server installation to
>> >which
>> > > >you
>> > > > > > >want
>> > > > > > > >to
>> > > > > > > > > >> >>connect.  Do this by typing the following at the
>>MS-DOS
>> > > > >prompt:
>> > > > > > > > > >> >
>> > > > > > > > > >> >
>> > > > > > > > > >> >>set ssdir=\\server\share\vss
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>Where \\server\share\vss is the folder where the
>> > > >srcsafe.ini
>> > > > > >file
>> > > > > > > >is
>> > > > > > > > > >> >>located."
>> > > > > > > > > >> >
>> > > > > > > > > >> >I am a little confused here. When I go to file->open
>> > > > >SourceSafe
>> > > > > > > > > >>database,
>> > > > > > > > > >> >in the windows that is open, the name of the database
>>is
>> > > >shown
>> > > > > > >Asset
>> > > > > > > > > >> >Planner
>> > > > > > > > > >> >2 and its path is shown
>>\\Cds-main\VssDb\AssetPlannerII.
>> > > > > > > > > >> >And i have srcsafe.ini file in both
>> > > > > > > > > >>"\\Cds-main\VssDb\AssetPlannerII-Conf"
>> > > > > > > > > >> >and "\\Cds-main\VssDb\AssetPlannerII". But neither if
>> >them
>> > > > >have
>> > > > > > > >worked
>> > > > > > > > > >>???
>> > > > > > > > > >> >error message
>> > > > > > > > > >> >
>> > > > > > > > > >> >D:\ap2\javasrc\server>ant getcode
>> > > > > > > > > >> >Buildfile: build.xml
>> > > > > > > > > >> >
>> > > > > > > > > >> >getcode:
>> > > > > > > > > >> >
>> > > > > > > > > >> >BUILD FAILED
>> > > > > > > > > >> >
>> > > > > > > > > >> >D:\ap2\javasrc\server\build.xml:67:
>>java.io.IOException:
>> > > > > > > > >CreateProcess:
>> > > > > > > > > >> >\\Cds-main\VssDb\A
>> > > > > > > > > >> >ssetPlannerII-Conf\ss Get "$/Asset Planner 2"
>>-GLD:\ap2
>> > >-I-
>> > > >-R
>> > > > > >-W
>> > > > > > > > > >> >"-Yttraub,
>> > > > > > > > > >> >ttraub"  erro
>> > > > > > > > > >> >r=2
>> > > > > > > > > >> >--- Nested Exception ---
>> > > > > > > > > >> >java.io.IOException: CreateProcess:
>> > > > > > > > > >>\\Cds-main\VssDb\AssetPlannerII-Conf\ss
>> > > > > > > > > >> >Get "$/Asset P
>> > > > > > > > > >> >lanner 2" -GLD:\ap2 -I- -R -W "-Yttraub, ttraub"
>> >error=2
>> > > > > > > > > >> >        at java.lang.Win32Process.create(Native
>>Method)
>> > > > > > > > > >> >        at
>> > > >java.lang.Win32Process.<init>(Win32Process.java:64)
>> > > > > > > > > >> >        at java.lang.Runtime.execInternal(Native
>>Method)
>> > > > > > > > > >> >        at java.lang.Runtime.exec(Runtime.java:272)
>> > > > > > > > > >> >        at
>> > > > > > > > > >>
>> > > > > > > > >
>> > > > > > > >
>> > > > > > >
>> > > > > >
>> > > > >
>> > > >
>> > >
>> >
>>
>org.apache.tools.ant.taskdefs.Execute$CommandLauncher.exec(Execute.java:435
>> > > > > > > > > >>)
>> > > > > > > > > >> >        at
>> > > > > > > > > >>
>> > > > > > > > >
>> > > > > > > >
>> > > > > > >
>> > > > > >
>> > > > >
>> > > >
>> > >
>> >
>>
>org.apache.tools.ant.taskdefs.Execute$CommandLauncherProxy.exec(Execute.jav
>> > > > > > > > > >>a:55
>> > > > > > > > > >> >0)
>> > > > > > > > > >> >        at
>> > > > > > > > > >>
>> > > > > > > > >
>> > > > > > > >
>> > > > > > >
>> > > > > >
>> > > > >
>> > > >
>> > >
>> >
>>
>org.apache.tools.ant.taskdefs.Execute$WinNTCommandLauncher.exec(Execute.jav
>> > > > > > > > > >>a:57
>> > > > > > > > > >> >5)
>> > > > > > > > > >> >        at
>> > > > > > > > >
>> > > > >>org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:329)
>> > > > > > > > > >> >        at
>> > > > > > > > > >>
>> > > > > > >
>> > > >
>> >org.apache.tools.ant.taskdefs.optional.vss.MSVSS.run(MSVSS.java:160)
>> > > > > > > > > >> >        at
>> > > > > > > > > >>
>> > > > > > > > >
>> > > > > > > >
>> > > > > > >
>> > > > > >
>> > > > >
>> > > >
>> > >
>> >
>>
>org.apache.tools.ant.taskdefs.optional.vss.MSVSSGET.execute(MSVSSGET.java:1
>> > > > > > > > > >>68)
>> > > > > > > > > >> >        at
>> > >org.apache.tools.ant.Target.execute(Target.java,
>> > > > > > >Compiled
>> > > > > > > > > >>Code)
>> > > > > > > > > >> >        at
>> > > > > > >org.apache.tools.ant.Project.runTarget(Project.java:898)
>> > > > > > > > > >> >        at
>> > > > > > >org.apache.tools.ant.Project.executeTarget(Project.java,
>> > > > > > > > > >> >Compiled
>> > > > > > > > > >> >Code)
>> > > > > > > > > >> >        at
>> > > > > > >org.apache.tools.ant.Project.executeTargets(Project.java,
>> > > > > > > > > >> >Compiled Code)
>> > > > > > > > > >> >        at
>>org.apache.tools.ant.Main.runBuild(Main.java,
>> > > > > >Compiled
>> > > > > > > > >Code)
>> > > > > > > > > >> >        at
>>org.apache.tools.ant.Main.main(Main.java:149)
>> > > > > > > > > >> >
>> > > > > > > > > >> >Total time: 6 seconds
>> > > > > > > > > >> >
>> > > > > > > > > >> >I remember getting this message before but i can't
>> > >remember
>> > > > >what
>> > > > >
>> > > > > >i
>> > > > > > > >did
>> > > > > > > > > >>to
>> > > > > > > > > >> >get rid of it :(
>> > > > > > > > > >> >
>> > > > > > > > > >> >>As far as my second:
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>What I meant was to open a command-line window and,
>> > > >assuming
>> > > > > >you
>> > > > > > > >have
>> > > > > > > > > >> >>ss.exe
>> > > > > > > > > >> >>in your path, extract the source code running ss 
>>get.
>> > >You
>> > > > >can
>> > > > > > >see
>> > > > > > > > > >>VSS's
>> > > > > > > > > >> >>help for running ss get.   What I was trying to get
>>at
>> > >here
>> > > > >was
>> > > > > > >to
>> > > > > > > > >not
>> > > > > > > > > >>run
>> > > > > > > > > >> >>ant's vssget but just plain ss get to extract source
>> > >code.
>> > > > > > > > > >> >
>> > > > > > > > > >> >I have ss.exe in d:\Program
>> > > > > >Files\MicrosoftVisualStudio\VSS\win32
>> > > > > > > > > >> >
>> > > > > > > > > >> >I think it's working right. when I perform ss get 
>>from
>> >the
>> > > > > >command
>> > > > > > > > >line
>> > > > > > > > > >>it
>> > > > > > > > > >> >asks for username and pasword, but it couldn; tfind 
>>my
>> > > > >username
>> > > > > > >and
>> > > > > > > > > >> >password
>> > > > > > > > > >> >i think it's been changed recently :)
>> > > > > > > > > >> >
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>HTH,
>> > > > > > > > > >> >>Felice
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>-----Original Message-----
>> > > > > > > > > >> >>From: Pinar Bicioglu [mailto:pinarbici@hotmail.com]
>> > > > > > > > > >> >>Sent: Tuesday, June 05, 2001 2:56 PM
>> > > > > > > > > >> >>To: ant-user@jakarta.apache.org
>> > > > > > > > > >> >>Subject: RE: doing SourceSafe get
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>
>> > > > > > > > > >> >> >From: "Vittoria, Felice" <Felice_Vittoria@bmc.com>
>> > > > > > > > > >> >> >Reply-To: ant-user@jakarta.apache.org
>> > > > > > > > > >> >> >To: "'ant-user@jakarta.apache.org'"
>> > > > > > ><ant-user@jakarta.apache.org>
>> > > > > > > > > >> >> >Subject: RE: doing SourceSafe get
>> > > > > > > > > >> >> >Date: Tue, 5 Jun 2001 14:44:13 -0500
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >Hmm .. I guess what I meant was the database on a
>> > > >different
>> > > > > > > >server?
>> > > > > > > > > >>If
>> > > > > > > > > >> >> >it's
>> > > > > > > > > >> >> >on a different server then you may need to make
>> > > >additional
>> > > > > > > > > >>configuration
>> > > > > > > > > >> >> >changes to your PC before running ant.
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>Oh I am sorry about that. yes you're right it is on 
>>a
>> > > > >different
>> > > > > > > > >server!
>> > > > > > > > > >> >>What kind of configurations do i need to make. Is
>>there
>> > >any
>> > > > > > > > > >>documentation
>> > > > > > > > > >> >>on
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>that that i can use ??
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >Also, if you perform the ss get command from the
>> > > > > >command-line,
>> > > > > > > >will
>> > > > > > > > > >>it
>> > > > > > > > > >> >> >produce the same error as ant or will it work
>> > >correctly?
>> > > > > > > > > >> >>
>> > > > > > > > > >> >>I don't think that I understand what you mean. the
>> >error
>> > > > > >message
>> > > > > > > > > >>Iposted
>> > > > > > > > > >> >>in
>> > > > > > > > > >> >>my earlier message gets generated when I write "ant
>> > > >getcode"
>> > > > >in
>> > > > >
>> > > > > >a
>> > > > > > > > > >>command
>> > > > > > > > > >> >>line.
>> > > > > > > > > >> >>
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >-----Original Message-----
>> > > > > > > > > >> >> >From: Pinar Bicioglu 
>>[mailto:pinarbici@hotmail.com]
>> > > > > > > > > >> >> >Sent: Tuesday, June 05, 2001 2:39 PM
>> > > > > > > > > >> >> >To: ant-user@jakarta.apache.org
>> > > > > > > > > >> >> >Subject: RE: doing SourceSafe get
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >It is actually both. It is different database and
>> > > >differen
>> > > > > > > >project.
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >the database was APJUL2000 and the project's name
>>was
>> > > > > > > > >$/AP2.0{struts}
>> > > > > > > > > >> >> >before
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >with the code below.
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> ><target name="getcode">
>> > > > > > > > > >> >> >       <vssget vsspath="$/AP2.0(struts)"
>> > > > > > > > > >> >> >          login="ttraub, ttraub"
>> > > > > > > > > >> >> >          writable="true"
>> > > > > > > > > >> >> >          localpath="D:/ap20"
>> > > > > > > > > >> >> >          recursive="true"
>> > > > > > > > > >> >> >          ssdir="D:/Program Files/Microsoft Visual
>> > > > > > > > >Studio/VSS/win32"
>> > > > > > > > > >>/>
>> > > > > > > > > >> >> >   </target>
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >Now the database is Asset Planner 2 and the
>>project's
>> > > >name
>> > > > >is
>> > > > > > >the
>> > > > > > > > > >>same
>> > > > > > > > > >> >> >which
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >is $/Asset Planner 2 with the following code.
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> ><target name="getcode">
>> > > > > > > > > >> >> >       <vssget vsspath="$/Asset Planner 2"
>> > > > > > > > > >> >> >          login="ttraub, ttraub"
>> > > > > > > > > >> >> >          writable="true"
>> > > > > > > > > >> >> >          localpath="D:/ap2"
>> > > > > > > > > >> >> >          recursive="true"
>> > > > > > > > > >> >> >          ssdir="D:/Program Files/Microsoft Visual
>> > > > > > > > >Studio/VSS/win32"
>> > > > > > > > > >>/>
>> > > > > > > > > >> >> >   </target>
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >> > >From: "Vittoria, Felice"
>><Felice_Vittoria@bmc.com>
>> > > > > > > > > >> >> > >Reply-To: ant-user@jakarta.apache.org
>> > > > > > > > > >> >> > >To: "'ant-user@jakarta.apache.org'"
>> > > > > > > ><ant-user@jakarta.apache.org>
>> > > > > > > > > >> >> > >Subject: RE: doing  SourceSafe get
>> > > > > > > > > >> >> > >Date: Tue, 5 Jun 2001 14:15:18 -0500
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >Are you getting the code from a different
>>database
>> >or
>> >
>> > >a
>> > > > > > > >"project"
>> > > > > > > > > >> >>within
>> > > > > > > > > >> >> > >that database?   Also, what values did you
>>change?
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >-----Original Message-----
>> > > > > > > > > >> >> > >From: Pinar Bicioglu
>>[mailto:pinarbici@hotmail.com]
>> > > > > > > > > >> >> > >Sent: Tuesday, June 05, 2001 2:06 PM
>> > > > > > > > > >> >> > >To: ant-user@jakarta.apache.org
>> > > > > > > > > >> >> > >Subject: doing SourceSafe get
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >I worked with "vssget" task before and it was
>> > >working.
>> > > > >this
>> > > > > > > >time
>> > > > > > > > >I
>> > > > > > > > > >>had
>> > > > > > > > > >> >>to
>> > > > > > > > > >> >> > >get the code from a different database. And
>>somehow
>> > > >it's
>> > > > > >not
>> > > > > > > > > >>working.
>> > > > > > > > > >> >>I
>> > > > > > > > > >> >> > >don't understand what makes the difference.
>> > > > > > > > > >> >> > >I have the code as below
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > ><target name="getcode">
>> > > > > > > > > >> >> > >       <vssget vsspath="$/Asset Planner 2"
>> > > > > > > > > >> >> > >          login="pinarb, pinarb"
>> > > > > > > > > >> >> > >          writable="true"
>> > > > > > > > > >> >> > >          localpath="D:/ap2"
>> > > > > > > > > >> >> > >          recursive="true"
>> > > > > > > > > >> >> > >          ssdir="D:/Program Files/Microsoft
>>Visual
>> > > > > > > > > >>Studio/VSS/win32"
>> > > > > > > > > >> >>/>
>> > > > > > > > > >> >> > >   </target>
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >it generates an error message like this...
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >D:\ap2\javasrc\server>ant getcode
>> > > > > > > > > >> >> > >Buildfile: build.xml
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >getcode:
>> > > > > > > > > >> >> > >    [vssget] $/Asset Planner 2 is not an 
>>existing
>> > > > >filename
>> > > > > >or
>> > > > > > > > > >>project
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >BUILD FAILED
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >D:\ap2\javasrc\server\build.xml:66: Failed
>> >executing:
>> > > > > > > >"D:\Program
>> > > > > > > > > >> >> > >Files\Microsoft Visual S
>> > > > > > > > > >> >> > >tudio\VSS\win32\ss" Get "$/Asset Planner 2"
>> >-GLD:\ap2
>> > > >-I-
>> > > > > >-R
>> > > > > > >-W
>> > > > > > > > > >> >> >"-Yttraub,
>> > > > > > > > > >> >> > >ttraub"
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >Total time: 3 seconds
>> > > > > > > > > >> >> > >
>> > > > > > > > > >> >> > >is it about changin the mode of the file.
>>Actually
>> >I
>> > > >even
>> > > > > > >tried
>> > > > > > > > > >>this
>> > > > > > > > > >> >>but
>> > > > > > > > > >> >> >it
>> > > > > > > > > >> >> > >didn't work
>> > > > > > > > > >> >> >
>> > > > > > > >
>> > > >_________________________________________________________________
>> > > > > > > > > >> >> > >Get your FREE download of MSN Explorer at
>> > > > > > > >http://explorer.msn.com
>> > > > > > > > > >> >> >
>> > > > > > > > > >> >>
>> > > > > > >
>> > >_________________________________________________________________
>> > > > > > > > > >> >> >Get your FREE download of MSN Explorer at
>> > > > > > >http://explorer.msn.com
>> > > > > > > > > >> >>
>> > > > > > > > > >>
>> > > > > >
>> > >>_________________________________________________________________
>> > > > > > > > > >> >>Get your FREE download of MSN Explorer at
>> > > > > >http://explorer.msn.com
>> > > > > > > > > >> >
>> > > > > > > > > >>
>> > > > > >
>> >_________________________________________________________________
>> > > > > > > > > >> >Get your FREE download of MSN Explorer at
>> > > > > >http://explorer.msn.com
>> > > > > > > > > >> >
>> > > > > > > > > >>
>> > > > > > > > >
>> > > > >
>> >>_________________________________________________________________
>> > > > > > > > > >>Get your FREE download of MSN Explorer at
>> > > > >http://explorer.msn.com
>> > > > > > > > > >
>> > > > > > > > >
>> > > > >_________________________________________________________________
>> > > > > > > > > >Get your FREE download of MSN Explorer at
>> > > >http://explorer.msn.com
>> > > > > > > > > >
>> > > > > > > > >
>> > > > > > > >
>> > > >_________________________________________________________________
>> > > > > > > > >Get your FREE download of MSN Explorer at
>> > >http://explorer.msn.com
>> > > > > > > >
>> > > > > > >
>> > >_________________________________________________________________
>> > > > > > > >Get your FREE download of MSN Explorer at
>> >http://explorer.msn.com
>> > > > > > >
>> > > > > >
>> >_________________________________________________________________
>> > > > > > >Get your FREE download of MSN Explorer at
>>http://explorer.msn.com
>> > > > > >
>> > > > > 
>> >_________________________________________________________________
>> > > > > >Get your FREE download of MSN Explorer at 
>>http://explorer.msn.com
>> > > > >
>> > > > >_________________________________________________________________
>> > > > >Get your FREE download of MSN Explorer at http://explorer.msn.com
>> > > >
>> > > >_________________________________________________________________
>> > > >Get your FREE download of MSN Explorer at http://explorer.msn.com
>> > >
>> > >_________________________________________________________________
>> > >Get your FREE download of MSN Explorer at http://explorer.msn.com
>> >
>> >_________________________________________________________________
>> >Get your FREE download of MSN Explorer at http://explorer.msn.com
>>
>>_________________________________________________________________
>>Get your FREE download of MSN Explorer at http://explorer.msn.com
>
>_________________________________________________________________
>Get your FREE download of MSN Explorer at http://explorer.msn.com
>

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com

Mime
View raw message