ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart Boyd <sboyd_78...@yahoo.com>
Subject Re: win2k, mapper, regexp problem
Date Tue, 26 Jun 2001 18:19:27 GMT
Sorry for the repetition.  I just found the thread at
http://marc.theaimsgroup.com/?l=ant-user&m=99305313530985&w=2


--- Stuart Boyd <sboyd_78759@yahoo.com> wrote:
> Hello,
> 
> I am using the following target to execute the copy
> task:
> <target name="make_com">
>    <!-- Collect all the com src dirs into a single
> com
> directory -->
> 	<mkdir dir="${com_dir}"/>
> 	<copy todir="${com_dir}">
> 	   <fileset dir="atf" />
>   	   <mapper type="regexp" from=".*/com/(.*)"
> to="\1"
> />
> 	</copy>
> </target>
> 
> The command works fine on my Solaris box but it
> fails
> on my Win2K professional, using either the regexp
> 1.2
> or the ORO 2.0.2 packages.
> 
> The message I see when I run it on win2k with
> -verbose
> is:
> [copy] test\com\blah skipped - don't know how to
> handle it
> 
> This message appears for every directory.  If I
> remove
> the "/"s from the pattern, the fileset gets created,
> just not as I need.
> 
> I'm using Ant 1.3 and tried both regexp 1.2 and ORO
> 2.0.2.
> 
> Thanks for any help pointing out my mistake.
> 
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Get personalized email addresses from Yahoo! Mail
> http://personal.mail.yahoo.com/


__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

Mime
View raw message