ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "O'Hara, Patrick" <patrick.oh...@workscape.com>
Subject RE: More issues with Ant and Starteam
Date Tue, 05 Jun 2001 15:49:29 GMT
The StarTeam task is in the optional taskdefs under scm.  I am aware of the
issues involved, the code for the task does not directly try to create a
task with touch.

Pat O'Hara
pdohara@techneex.com


-----Original Message-----
From: Bill.J.Fellows@mail.sprint.com
[mailto:Bill.J.Fellows@mail.sprint.com]
Sent: Tuesday, June 05, 2001 10:19 AM
To: ant-user@jakarta.apache.org
Subject: RE: More issues with Ant and Starteam


On your touch issue, it sounds like startteam task is a homegrown task 
(at least I don't see it in the optional stuff)  
It appears that you are trying to execute touch on a windows machine.  
Touch, AFAIK, is a unix specific command (not in the free NT resource 
kit at least).  Could you use the touch task?

-----Original Message-----
From: patrick.ohara [mailto:patrick.ohara@workscape.com]
Sent: Tuesday, June 05, 2001 9:03 AM
To: ant-user
Subject: More issues with Ant and Starteam


Since I was unable to figure out the touch issue with the starteam 
task, I have decided to abandon the task in favor of the command line 
interface.  Ant is complaining about the exec task below.
        <exec executable="stcmd" dir="$build.basedir"> 
          <arg line=" co -p 
"$starteam.username:$starteam.password@$starteam.servername:$starteam.po
rt/$starteam.projname/$starteam.viewname/dev/DeploymentDescriptors" 
-fs"/>
        </exec> 
The error I get dose not make much sense: 
        C:.xml:90: Whitespace required before attributes. 
I have determined that the issue is the quotes within the command line. 
 I have tried replacing the " with the &quot; macro, but I got 
"Reference to undefined entity".  I even tried using &quote; just in 
case.  I am wondering if anyone has an example of a command line that 
has embedded quotes in it?  I am using ANT 1.3 on Win2K.
Patrick D O'Hara 
N17 W24222 Riverwood Dr, 
Suite 330 
Waukesha, WI 53188-1162 
(262)408-3849 
(262)408-3840 Fax 

Mime
View raw message