ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "O'Hara, Patrick" <patrick.oh...@workscape.com>
Subject More issues with Ant and Starteam
Date Tue, 05 Jun 2001 14:03:21 GMT
Since I was unable to figure out the touch issue with the starteam task, I
have decided to abandon the task in favor of the command line interface.
Ant is complaining about the exec task below.

	<exec executable="stcmd" dir="${build.basedir}">
	  <arg line=" co -p
\"${starteam.username}:${starteam.password}@${starteam.servername}:${startea
m.port}/${starteam.projname}/${starteam.viewname}/dev/DeploymentDescriptors\
" -fs"/>
	</exec>

The error I get dose not make much sense:

	C:\weblogic\CoventryDevelopment\build.xml:90: Whitespace required
before attributes.

I have determined that the issue is the quotes within the command line.  I
have tried replacing the \" with the &quot; macro, but I got "Reference to
undefined entity".  I even tried using &quote; just in case.  I am wondering
if anyone has an example of a command line that has embedded quotes in it?
I am using ANT 1.3 on Win2K.

Patrick D O'Hara
N17 W24222 Riverwood Dr,
Suite 330
Waukesha, WI 53188-1162
(262)408-3849
(262)408-3840 Fax


Mime
View raw message