ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Klaus Thorwart <K.Thorw...@rose.de>
Subject javadoc-task: HTML-Code for the doctitle attribute
Date Wed, 06 Jun 2001 16:46:41 GMT
Hi all,

I have set up a javadoc task for our software which works fine, as long
as I use only pure text for the values of the attributes of doctitle,
bottom and header. As soon as I try to use real HTML-Tags within these
values I get messages like the following:

ant -buildfile tmp.xml
Buildfile: tmp.xml

BUILD FAILED

/klaus-dev/RODON-II/LM/rodonII/tmp.xml:19: Use "&lt;" for "<" in
attribute values.

Total time: 2 seconds


The corresponding xml-file has the following contents:

<project name="simpleCompile" default="docs" basedir=".">
   <target name="init">
      <property name="sourceDir" value="src" />
      <property name="tstSourceDir" value="tstsrc" />
      <property name="outputDir" value="cls" />
      <property name="tstOutputDir" value="tstcls" />
      <property name="build.compiler" value="modern" />
      <property name="reports.tests" value="tstcls" />
   </target>
   <target name="docs" depends="init">
     <javadoc packagenames="x.y.z"
           classpath="${outputDir}:${tstOutputDir}:bin/AcmeCrypto.jar"
           sourcepath="src"
           destdir="reference"
           author="true"
           version="true"
           use="true"
           windowtitle="RODON II Reference"
           doctitle="<h1>RODON</h1>">
     </javadoc>
   </target>
</project>

Does anybody know how to solve this problem ?

Thanks in advance
  Klaus

Mime
View raw message