ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From (Will Hartung)
Subject Re: Ant Problems, Win 2000
Date Thu, 07 Jun 2001 22:45:44 GMT
One thing that may (possibly) be locking those files is either Fast Find
from MSOffice, or the Indexing system that's part of the Search...
functionality off of the Start menu.

The Indexing system likes to grab new directories and lock them while it is
scanning and updating its index.

Look for Indexing Service in your Search dialog.

Best Regards,

Will Hartung

----- Original Message -----
From: "Jamie Tsao" <>
To: <>
Sent: Thursday, June 07, 2001 2:55 PM
Subject: RE: Ant Problems, Win 2000

That's what I figured originally, so I basically just tried running my
"prepare" target first, which only copies files over, then I run the
"clean" target, which deletes those files.  No process could possible be
using those files at that point, but I still get the errors.

Ideas ?  Possible bug ?

- Jamie

-----Original Message-----
From: Jesse Tilly []
Sent: Thursday, June 07, 2001 2:50 PM
To: ''
Subject: RE: Ant Problems, Win 2000

If the files are being used by another process, Win2k, by default puts a
lock on these files.  Hence, you will receive an error on delete.


> -----Original Message-----
> From: Jamie Tsao []
> Sent: Thursday, June 07, 2001 5:27 PM
> To:
> Subject: Ant Problems, Win 2000
> Hi,
> I've used Ant before on a Solaris, and found it to be quite a
> reliable,
> stable build tool.  I'm currently using it on a Win 2K platform, and
> have run into some strange bugs.
> Bug 1:
> For some reason, the delete task doesn't behave properly
> sometimes.  For
> my "clean" target, I'm deleting the an entire directory.
> That directory
> contains .class files, config files, jar files, etc.  Certain
> jar files
> cannot be deleted for some reason.  I get the error message:
>  [delete]:  Cannot delete ......
> When I renamed the file to sometime else, it was fine.  There seems to
> be a bunch of inconsistencies because today I renamed the file to the
> original name, and it worked.  1 hour later, it didn't work again !!
> Anyone know why ?
> Bug 2:
> There's one particular jar that I'm copying over to the deployment
> directory that is causing weird warnings.  For some reason,
> when use the
> copy task to copy the jar to the deployment directory, the "modified"
> timestamp on the jar is changed to the current time.  The Ant gives me
> some warning about future modified files. Anyone ?
> Thanks,
> - Jamie

View raw message