ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Saupp" <asa...@gmx.de>
Subject Question: How to make ant running with cvs
Date Tue, 19 Jun 2001 12:38:40 GMT
Hi, 

i tried to make Ant running with CVS. Is there an additional jar i need? I guess no. A cvs
client is
installed, up and running, I am able to access the CVS server on cmd line.

If I create ant tasks like the following, I receive the exception above:

 <target name="getJSPs">
  <cvs cvsRoot=":pserver:asaupp@xx.xx.200.141:/cvsdata" command="history -a"/>
 </target>

This is runinng on command line, but not in ant.

getJSPs:

BUILD FAILED

C:\DEPLOY\config\build.xml:106: java.io.IOException: CreateProcess: cvs -d :pserver:asaupp@xx.xx.200.141:/cvsdata
history -a error=2
--- Nested Exception ---
java.io.IOException: CreateProcess: cvs -d :pserver:asaupp@xx.xx.200.141:/cvsdata history
-a error=2
        at java.lang.Win32Process.create(Native Method)
        at java.lang.Win32Process.<init>(Unknown Source)
        at java.lang.Runtime.execInternal(Native Method)
        at java.lang.Runtime.exec(Unknown Source)
        at java.lang.reflect.Method.invoke(Native Method)
        at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:509)
        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:329)
        at org.apache.tools.ant.taskdefs.Cvs.execute(Cvs.java:181)
        at org.apache.tools.ant.Target.execute(Target.java:153)
        at org.apache.tools.ant.Project.runTarget(Project.java:898)
        at org.apache.tools.ant.Project.executeTarget(Project.java:536)
        at org.apache.tools.ant.Project.executeTargets(Project.java:510)
        at org.apache.tools.ant.Main.runBuild(Main.java:421)
        at org.apache.tools.ant.Main.main(Main.java:149)

Total time: 1 second

CVS server uses passowrd authentication, may be that's a problem? How to configure cvs to
get a one line login?
cvs -d :pserver:asaupp:thepass@xx.xx.200.141:/cvsdata login 
wasn't working.

Any idea what the reason could be? Thanks.

Alex

Mime
View raw message