ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J. Michael Caine" <jmca...@alum.rpi.edu>
Subject RE: "jar" task failing
Date Thu, 21 Jun 2001 15:12:45 GMT
(sorry, this was a repost of an earlier post, please ignore it.  ... and i
am going to try the suggestions made to my earlier posts, though i think
i've already tried them... more to come.)

-----Original Message-----
From: J. Michael Caine [mailto:jmcaine@alum.rpi.edu]
Sent: Wednesday, June 20, 2001 12:38 PM
To: ant-user@jakarta.apache.org
Subject: "jar" task failing


i was running 1.2-1 (the only version for which i found a Debian package).
compilations and such seemed to work fine, but the "jar" task was failing,
giving me:

"Problem creating jar: ZIP file must have at least one entry"
at java.util.zip.ZipOutputStream.finish(ZipOutputStream.java:294)
<rest of stack trace>

so i just installed 1.3, the latest binaries, and pointed to that.  again,
it worked fine, except for the "jar" task.  so i suspect there's something
wrong with my syntax, but it sure looks a lot like the example code.  i
have:

<target name="dist" depends="compile">
	<jar jarfile="${basedir}/build/it.jar" basedir="${basedir}/build"/>
</target>

could it be a problem with my java?  i have J2SDK 1.3.0-2.

oh, of course, there are .class files (only) in ${basedir}/build/.  i
checked that.



Mime
View raw message