ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael 'Mickey' Sattler" <mich...@GeekTimes.com>
Subject Bug in default state? (was: How to build and run using ANT?)
Date Fri, 25 May 2001 11:06:28 GMT
This seems like a good place for me to delurk.

I recently downloaded Ant 1.3 to UN*X box, to use it in conjunction 
with a webapp I'm doing under Tomcat (so I'm the audience targeted by 
the default configuration). Here's where things get wierd: I do a 
build with the provided build.xml and the prepare step informs me that

[mkdir] Created dir: 
/Users/mickey/apps/java/jakarta/tomcat-3.2.1/webapps/lims/${tomcat.home}/webapps/lims

It seems that ${tomcat.home} is being correctly expanded, then 
"webapps/lims" properly added, and then the literal string 
"${tomcat.home}" and the "webapps/lims" added (inappropriately) again.

I fixed it thusly:

   <property name="app.name"       value="lims"/>
<!--
   BROKEN? Yields /correct/path/webapps/lims/${tomcat.home}/webapps/lims
   <property name="deploy.home"    value="${tomcat.home}/webapps/${app.name}"/>
-->
   <property name="deploy.home"
     value="/Users/mickey/apps/java/jakarta/tomcat-3.2.1/ webapps/${app.name}"/>
   <property name="dist.home"      value="${deploy.home}"/>

Given that I haven't seen this mentioned on the list archives (not 
that they were easy to search :-) I'm guessing that it's something in 
my configuration - since I didn't have time to break the installation 
- but I can't figure out what, since it seems rather straightforward.

Help would be appreciated. I have a work-around, but no understanding.

Michael

-- 
Michael "Mickey" Sattler, Geek Times   <mailto:michael@GeekTimes.com>
San Francisco, California, USA    <http://www.GeekTimes.com/michael/>

I was born not knowing and have had only a little time to change that here
and there. -- Richard Feynman (1918 - 1988)

Mime
View raw message