ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Nicholson" <rob...@elastica.com>
Subject RE: WL 6.0 EJBC Ant build
Date Tue, 22 May 2001 19:33:34 GMT
This is because you don't have a parser set for the jaxp framework to work.

when you run ant define the property

javax.xml.parsers.DocumentBuilderFactory  to point to the
DocumentBuilderFactory you want to use.

For me go and grab jax1.1 and look at the docs for the
newInstance methodo of DocumentBuilderFactory
-----Original Message-----
From: Schmoll, Brett x66244 [mailto:BSchmoll@bis.adp.com]
Sent: Tuesday, May 22, 2001 9:42 AM
To: ant-user@jakarta.apache.org
Subject: WL 6.0 EJBC Ant build


Does anyone have a working Weblogic 6.0 EJBC task that they could share with
me? I'm able to get the EJBC built from a command prompt but don't seem to
be able to get it to work under Ant. Here is the Taskdef I'm using, am I
missing the obvious?
<java
classpath="d:\develop\posse_jvm_4_3_1\temp\posse_jar;c:\jdk1.3\lib\tools.jar
;c:\bea\wlserver6.0sp1\lib\weblogic.jar;c:\weblogic\classes;"
classname="weblogic.ejbc" >
        <arg path="d:\develop\posse_jvm_4_3_1\temp\header.jar" />  Do you
have
        <arg path="d:\develop\posse_jvm_4_3_1\temp\header4_3_1.jar" />
</java>
I receive a "javax.xml.parsers.FactoryConfigurationError:" when this runs
under Ant. I run what I assume to be the equivalent from a command prompt
and it builds fine. Any help would be greatly appreciated.
Thanks,
Brett Schmoll


Mime
View raw message