ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Webb, James" <james.w...@vignette.com>
Subject v1.3 -- problems retrieving properties from <property file="SOMEF ILE">
Date Tue, 01 May 2001 23:11:50 GMT
Are there any known issues in 1.3 or config tricks for 
retrieving properties from a properties file?
I have not seen any bugreports or patches for this kind
of issue.

I am trying to set up a properties file containing
local configuration such as paths,etc. for each developer's
specific environment.

/bldenv	
	./build.xml --> main buildfile common to all developers
	./local.properties --> specific for each developer env
	

Things I have tried in my build.xml

1. using...
	<property file="local.properties"/>

   results in...
	while in verbose mode when i echo any property 
	contained within the file it says...
			
	"Property ${weblogic.install.home} has not been set"
		
	I have also tested the property value with
	the <mail> task and the <mkdir> task so I am 
	certain my problem is in the <property> task
	and not in <echo>.
	
2. using...

	<property resource="local.properties"/>
	and placing the file in my CLASSPATH

   results...
	I get the same result as before.

3.   I have tried three different properties files
	to make certain it was not an encoding issue.
	This did not solve my problem.

4.   My only workaround is to set these properties as
	environment variables and grab them via
	<property environment="MYENV"/>
	I can get this to work but it is not as clean.

Ant Version: 1.3
OS: Windows 2000
JDK: Sun 1.3.0_02


Any help would be greatly appreciated.


James Webb

Mime
View raw message