ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Les Hughes <leslie.hug...@rubus.com>
Subject RE: EJB problem with EJBc in IAS 6.0 Sp2
Date Thu, 17 May 2001 11:29:20 GMT
Just a guess LD_LIBRARY_PATH ? Link errors are usually caused by missing .so
(shared library) files - EJBc looks like it's trying to load a library.


> -----Original Message-----
> From: jaideep satghare [mailto:jaideep_ant@yahoo.co.in]
> Sent: 17 May 2001 11:17
> To: ant-user@jakarta.apache.org
> Subject: EJB problem with EJBc in IAS 6.0 Sp2
> 
> 
> Hello people,
> 
> I am using the Ant1.2 to create a JAR archive for an
> EJB in my project. I get an error while creating the
> stubs and skeletons for the EJB in the UNIX
> environment of SunOS 5.8.
> I have used the com.kivasoft.ejbc.EJBc class provided
> by IPlanet Application Server (IAS) 6.0 SP2 to
> generate the stubs and skeletons.
> But I get the following error in the SunOS 5.8
> environment.
> 
> 
> [exec] Exception in thread "main"
> java.lang.UnsatisfiedLinkError: no jx2types in
> java.library.path
> [exec]     at
> java.lang.Throwable.fillInStackTrace(Native Method)
> [exec]     at
> java.lang.Throwable.fillInStackTrace(Compiled Code)
> [exec]     at java.lang.Throwable.<init>(Compiled
> Code)
> [exec]     at java.lang.Error.<init>(Error.java:50)
> [exec]     at
> java.lang.LinkageError.<init>(LinkageError.java:43)
> [exec]     at
> java.lang.UnsatisfiedLinkError.<init>(UnsatisfiedLinkError.java:42)
> [exec]     at
> java.lang.ClassLoader.loadLibrary(Compiled Code)
> [exec]     at
> java.lang.Runtime.loadLibrary0(Runtime.java:471)
> [exec]     at
> java.lang.System.loadLibrary(System.java:745)
> [exec]     at <Unloaded Method>   
>      
>      
> The same code ,however, works ok on WinNT and
> generates the stubs and skeletons correctly.
> 
> For your reference, following is the target I use in
> my buildfile to create the EJB JAR archive
> 
> <target name="ejbjar">
> <echo message="Executing Step 2, creating the
> cswEJB.jar file." />
> <echo message="Please wait..." />
> 
> 
> <mkdir dir="${CSW_EJB_DIR}/META-INF" />
> <copy file="${DD_DIR}/META-INF/${EJB_DD_J2EE}"
> tofile="${CSW_EJB_DIR}/META-INF/${EJB_DD_J2EE}" />
> <copy file="${DD_DIR}/META-INF/${EJB_DD_IAS}"
> tofile="${CSW_EJB_DIR}/META-INF/${EJB_DD_IAS}" />
> 
>  <exec dir="${CSW_EJB_DIR}" 
>          executable="java">
> <arg line="-classpath ${IAS_CLASSPATH}
> com.kivasoft.ejbc.EJBc -sl
> ${EJB_DIR_PACKAGE}${EJBHomeClass}
> ${EJB_DIR_PACKAGE}${EJBRemoteClass}
> ${EJB_DIR_PACKAGE}${EJBImplClass}" />    
> </exec> 
> 
> <move todir="${EJB_DIR}">
> <fileset dir="${CSW_EJB_DIR}" includes="*.class" />
> </move>
> 
> <jar jarfile="${CSW_ARCHIVES}/${CSW_EJB_JAR}"
>   basedir="${CSW_EJB_DIR}"/>
> <echo message="Done." />        
> </target>
> 
> 
> If any of you out there have encountered anything
> similar or might be have any clues as to what might be
> the problem, please share them with me.
> 
> Thanks,
> Jaideep
> 
> 
> 
> ____________________________________________________________
> Do You Yahoo!?
> For regular News updates go to http://in.news.yahoo.com
> 

Mime
View raw message