ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: Bug in default state? (was: How to build and run using ANT?)
Date Fri, 25 May 2001 12:34:41 GMT
At 04:06 AM 5/25/01 -0700, Michael 'Mickey' Sattler wrote:
>This seems like a good place for me to delurk.
>
>I recently downloaded Ant 1.3 to UN*X box, to use it in conjunction 
>with a webapp I'm doing under Tomcat (so I'm the audience targeted by 
>the default configuration). Here's where things get wierd: I do a 
>build with the provided build.xml and the prepare step informs me that
>
>[mkdir] Created dir: 
>/Users/mickey/apps/java/jakarta/tomcat-3.2.1/webapps/lims/${tomcat.home}/we
bapps/lims
>
>It seems that ${tomcat.home} is being correctly expanded, then 
>"webapps/lims" properly added, and then the literal string 
>"${tomcat.home}" and the "webapps/lims" added (inappropriately) again.

nope - what seems to be happening (assuming that you are building from or
have projectdir refrencing
/Users/mickey/apps/java/jakarta/tomcat-3.2.1/webapps/lims/) is that it is
trying to resolve ${tomcat.home} which is unset and thus it does
./${tomcat.home}/webapps/lims. So place definition of tomcat.home before
this property. If that doesn't work send some more info and hopefully we
can fix it ;)


Cheers,

Pete

*-----------------------------------------------------*
| "Faced with the choice between changing one's mind, |
| and proving that there is no need to do so - almost |
| everyone gets busy on the proof."                   |
|              - John Kenneth Galbraith               |
*-----------------------------------------------------*


Mime
View raw message