ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: Environment handling "bug"
Date Fri, 11 May 2001 00:16:46 GMT
ok - if you update from CVS/nightly builds - it should be fixed ... I think ;)

At 08:03  10/5/01 -0400, David Corbin wrote:
>1.3
>
>Peter Donald wrote:
>> 
>> At 07:21  10/5/01 -0400, David Corbin wrote:
>> >e ran across a rather odd problem.  It's not a bug REALLY, but Ant
>> >could do a slightly better job of handling it.  For reasons unknown, on
>> >one particular WinME machine (the only one in use in our system - the
>> >others are Linux or Win2K), the environment looks something like this:
>> >
>> >a=b
>> >c=d
>> >xxxxxxxxxx
>> >e=f
>> >g=h
>> >i=j
>> >
>> >When ant is run on this machine we get an exception that strongly
>> >indicates it is because of this odd line in the environment  (sorry, I
>> >don't have the details handy, but I can get them if desired).  It seems
>> >like at the least, ant
>> >could silently ignore the xxxx line and move on...
>> 
>> Which version of ant is this ... IIRC I checked in a patch that *should*
>> fix this. (Namely when values of environment properties have a \n character
>> in them).
>> 
>> Cheers,
>> 
>> Pete
>> 
>> *-----------------------------------------------------*
>> | "Faced with the choice between changing one's mind, |
>> | and proving that there is no need to do so - almost |
>> | everyone gets busy on the proof."                   |
>> |              - John Kenneth Galbraith               |
>> *-----------------------------------------------------*
>
>
Cheers,

Pete

*-----------------------------------------------------*
| "Faced with the choice between changing one's mind, |
| and proving that there is no need to do so - almost |
| everyone gets busy on the proof."                   |
|              - John Kenneth Galbraith               |
*-----------------------------------------------------*


Mime
View raw message