ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Schmoll, Brett x66244" <BSchm...@bis.adp.com>
Subject RE: WL 6.0 EJBC Ant build
Date Wed, 23 May 2001 15:49:18 GMT
THANKS! The fork="yes" resolved the issue. I'm not sure why but I'm not
going to argue with results.

Thanks again.

-Brett

 

-----Original Message-----
From: Conor MacNeill [mailto:conor@cortexebusiness.com.au]
Sent: Tuesday, May 22, 2001 10:58 PM
To: ant-user@jakarta.apache.org
Subject: RE: WL 6.0 EJBC Ant build


Try fork="yes" in your java task
 

-----Original Message-----
From: Schmoll, Brett x66244 [mailto:BSchmoll@bis.adp.com]
Sent: Wednesday, 23 May 2001 12:46 PM
To: 'ant-user@jakarta.apache.org'
Subject: RE: WL 6.0 EJBC Ant build



Okay, I've looked at the docs for Jaxp and I believe that I understand what
needs to occur but I'm still falling short of the mark. I've added the
following property declaration:

                <property name="javax.xml.parsers.DocumentBuilderFactory"> 
                    <classpath> 
                              <pathelement
path="c:\bea\wlserver6.0sp1\lib\"/> 
                              <pathelement location="weblogic.jar"/> 
                    </classpath> 
                </property> 
Unfortunately, the build still fails with a "FactoryConfigurationError". I
noticed that both the weblogic.jar and ant\lib\jaxp.jar both implement the
DocumentBuilderFactory. Is this causing the build to fail? If I remove the
ant Jaxp.jar, the build immediately fails.

Any ideas? 

-----Original Message----- 
From: Robert Nicholson [ mailto:robert@elastica.com
<mailto:robert@elastica.com> ] 
Sent: Tuesday, May 22, 2001 1:34 PM 
To: ant-user@jakarta.apache.org 
Subject: RE: WL 6.0 EJBC Ant build 


This is because you don't have a parser set for the jaxp framework to work. 

when you run ant define the property 

javax.xml.parsers.DocumentBuilderFactory  to point to the 
DocumentBuilderFactory you want to use. 

For me go and grab jax1.1 and look at the docs for the 
newInstance methodo of DocumentBuilderFactory 
-----Original Message----- 
From: Schmoll, Brett x66244 [ mailto:BSchmoll@bis.adp.com
<mailto:BSchmoll@bis.adp.com> ] 
Sent: Tuesday, May 22, 2001 9:42 AM 
To: ant-user@jakarta.apache.org 
Subject: WL 6.0 EJBC Ant build 


Does anyone have a working Weblogic 6.0 EJBC task that they could share with

me? I'm able to get the EJBC built from a command prompt but don't seem to 
be able to get it to work under Ant. Here is the Taskdef I'm using, am I 
missing the obvious? 
<java 
classpath="d:\develop\posse_jvm_4_3_1\temp\posse_jar;c:\jdk1.3\lib\tools.jar

;c:\bea\wlserver6.0sp1\lib\weblogic.jar;c:\weblogic\classes;" 
classname="weblogic.ejbc" > 
        <arg path="d:\develop\posse_jvm_4_3_1\temp\header.jar" />  Do you 
have 
        <arg path="d:\develop\posse_jvm_4_3_1\temp\header4_3_1.jar" /> 
</java> 
I receive a "javax.xml.parsers.FactoryConfigurationError:" when this runs 
under Ant. I run what I assume to be the equivalent from a command prompt 
and it builds fine. Any help would be greatly appreciated. 
Thanks, 
Brett Schmoll 


Mime
View raw message