ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Schmoll, Brett x66244" <>
Subject RE: WL 6.0 EJBC Ant build
Date Wed, 23 May 2001 02:46:00 GMT
Okay, I've looked at the docs for Jaxp and I believe that I understand what
needs to occur but I'm still falling short of the mark. I've added the
following property declaration:

		<property name="javax.xml.parsers.DocumentBuilderFactory">
			      <pathelement location="weblogic.jar"/>
Unfortunately, the build still fails with a "FactoryConfigurationError". I
noticed that both the weblogic.jar and ant\lib\jaxp.jar both implement the
DocumentBuilderFactory. Is this causing the build to fail? If I remove the
ant Jaxp.jar, the build immediately fails.

Any ideas?

-----Original Message-----
From: Robert Nicholson []
Sent: Tuesday, May 22, 2001 1:34 PM
Subject: RE: WL 6.0 EJBC Ant build

This is because you don't have a parser set for the jaxp framework to work.

when you run ant define the property

javax.xml.parsers.DocumentBuilderFactory  to point to the
DocumentBuilderFactory you want to use.

For me go and grab jax1.1 and look at the docs for the
newInstance methodo of DocumentBuilderFactory
-----Original Message-----
From: Schmoll, Brett x66244 []
Sent: Tuesday, May 22, 2001 9:42 AM
Subject: WL 6.0 EJBC Ant build

Does anyone have a working Weblogic 6.0 EJBC task that they could share with
me? I'm able to get the EJBC built from a command prompt but don't seem to
be able to get it to work under Ant. Here is the Taskdef I'm using, am I
missing the obvious?
classname="weblogic.ejbc" >
        <arg path="d:\develop\posse_jvm_4_3_1\temp\header.jar" />  Do you
        <arg path="d:\develop\posse_jvm_4_3_1\temp\header4_3_1.jar" />
I receive a "javax.xml.parsers.FactoryConfigurationError:" when this runs
under Ant. I run what I assume to be the equivalent from a command prompt
and it builds fine. Any help would be greatly appreciated.
Brett Schmoll

View raw message