ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nico Seessle" <n...@apache.org>
Subject Re: System Environment variables don't work
Date Wed, 16 May 2001 20:17:10 GMT
----- Original Message -----
From: "Mark Chamness" <markc@cacheware.com>
To: <ant-user@jakarta.apache.org>
Sent: Wednesday, May 16, 2001 7:42 PM
Subject: RE: System Environment variables don't work


> This bug is
> http://nagoya.apache.org/bugzilla/show_bug.cgi?id=975
>
> It claims to be fixed but it's not.
> I checked the May 15th java sources,
> http://jakarta.apache.org/builds/jakarta-ant/nightly/2001-05-15/
>
> The problem file is
>  src/main/org/apache/tools/ant/taskdefs/Property.java
>
> The problem is with parsing of cygwin bash environment
> variables containing new lines, such as
> PS1=\[\033]0;\w\007
> \033[32m\]\u@\h \[\033[33m\w\033[0m\]
> $
>
I tried to reproduce this, but I failed. I was using the latest version from
CVS which should be the same (since there are not so many changes
currently).

I started the cygwin environment using C:\cygwin\cygwin.bat (I don't know
which shell is running by default) and the following build.xml worked.

<?xml version="1.0"?>

<project name="test" basedir="." default="test">

  <target name="test">
    <property environment="env"/>
  </target>

</project>

Then I executed 'bash' and tried again. It still worked. Then I executed
'bash ant' and it still worked. And yes, the PS1-variable is set.

Nico




Mime
View raw message