ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject Re: Optional jar snapshot
Date Thu, 03 May 2001 09:44:55 GMT
From: "Andrew Thompson" <andrewt@quidnunc.com>
To: <ant-user@jakarta.apache.org>
Sent: Thursday, May 03, 2001 1:32 PM
Subject: RE: Optional jar snapshot


> >From: Conor MacNeill
> >I have built a recent snapshot of the optional jar. This is a more
>
> Hi Conor,
>
> I believe from your earlier mail that this changes the <weblogic> task to
> use Weblogic 6's new ejb2.0 compiler/persistance layer rather than the
> wl5.1/ejb1.1 ejb compiler?

No, it uses the DTD to pick the right compiler. It can still be used for
EJB1.1 beans either under WL5.1 or WL6

>
> We're using the 5.1 persistance layer with wl6.0, mostly because we don't
> trust new code for something so major until its had at least a couple of
> service packs, and we know the 5.1 stuff works.

That is cool.

>
> So... for us this would be a big problem with ant 1.4, if we were forced
to
> use the new ejbc (or can it handle 5.1 and 6.0 stuff?). Perhaps adding a
> target="" attribute to the weblogic element would allow selection of the
> compiler to use in an elegant fashion. Or is this a non-issue?

It is a non-issue, but you can also supply the compiler class if you like
so that if there is a future change in WLS, you can override the Ant task's
defaults.

Conor



Mime
View raw message