ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Singer" <sin...@dcs-systeme.de>
Subject RE: JVC problem
Date Tue, 08 May 2001 08:28:11 GMT
I get following result when invoking jvc /?

Microsoft (R) Visual J++ Compiler Version 6.00.8343
Copyright (C) Microsoft Corp 1996-1998. All rights reserved.

Usage: JVC [options] <filename>

 /cp <classpath> set class path for compilation
 /cp:p <path>    prepend path to class path
 /cp:o[-]        print classpath
 /d <directory>  root directory for class file output
 /D <symbol>     define conditional compilation symbol
 /g[-]           full debug information (g:l, g:d)
   /g:l[-]       generate line numbers <default=none>
   /g:t[-]       generate debug tables <default=none>
 /nologo         don't display the copyright banner
 /nowarn         turn off warnings <default=warn>
 /nowrite        compile only - do not generate class files
 /O[-]           full optimization (O:I,O:J)
   /O:I[-]       optimize by inlining <default=no opt>
   /O:J[-]       optimize bytecode jumps <default=no opt>
 /ref[-]         recompile referenced classes if out of date
<default=enabled>
 /verbose        print messages about compilation progress
 /w{0-4}         set warning level <default=2>
 /wx[-]          treat warnings as errors
 /x              disable extensions <default=extensions disabled>
 /x-             enable extensions  <default=extensions disabled>

Ok, it's another version number, but your mentioned commands it should
understand.

Tom

|-----Original Message-----
|From: Nico Seessle [mailto:nico@apache.org]
|Sent: Monday, May 07, 2001 9:33 PM
|To: ant-user@jakarta.apache.org
|Subject: Re: JVC problem
|
|
|----- Original Message -----
|From: "Thomas Singer" <singer@dcs-systeme.de>
|To: <ant-user@jakarta.apache.org>
|Sent: Monday, May 07, 2001 12:10 PM
|Subject: JVC problem
|
|
|> Hello,
|>
|> I tried to use the ant 1.3 with jvc and get following exception when
|> executing:
|>
|[...]
|>
|> JVC (from our J++ installation; please, don't blame me!) is
|in the path,
|it
|> could be run on the command line. Ant itself is setup
|corrently, because
|it
|> works nice with SUNs Jdk1.3.
|>
|I just tried it with the jvc-compiler from the VJ++ installation and it
|works for me (before I always used the jvc.exe included with
|Microsofts "SDK
|for Java"). I used "Microsoft (R) Visual J++ Compiler Version
|6.00.8424" -
|what is your version? Maybe it does not understand one of the
|command line
|arguments? (/x-, /nologo or /nomessage) - they should all be
|printed if you
|execute "jvc /?".
|
|>
|> What's wrong? Why there something is told about jikes in the
|exception?
|
|It's just the temporary file which is named "jikes-*.tmp".
|
|Nico
|
|


Mime
View raw message