ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "K Plummer" <>
Subject Ant 1.2 javac classpath and classpath reference problems.
Date Sat, 21 Apr 2001 23:35:02 GMT

I using ANT 1.2 (WNT/W2KPRO)and Javasoft 1.3.0c and seem to be
having problems getting the JAVAC task to take the classpath. I first tried
using a
CLASSPATH reference giving the ID. Didn't seem to work, but I wasn't
sure I understand the syntax so....

Next, I tried setting the classpath property and then
using the classpath="${classpath}" construction in the javac.
Also appeared not to work.

It seems that whatever I may try, ANT 1.2 javac desires/requires
classpath be set via the OS CLASSPATH, always ignoring any and
everything specified in the buildfile by any and every possible means.

When I enable verbose to javac and peek at the output the
-classpath ant1.2 sends to java always seems to be that of the
CLASSPATH environmental, even if I use classpath=" " (no classpath
passed to the ant 1.2 javac task.

Most confused.... please help if possible.

View raw message