ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dcor...@machturtle.com
Subject Re: Delete fails (more)
Date Fri, 13 Apr 2001 12:06:41 GMT
Rebooting does not correc the problem.  In at least one case, cygnus rm did remove 
the file.  Also, please note that I am doing the exact same type of thing (expand 
and remove, both from ANT) with several other zip/tar/jar files, and none of them 
have the problem.  The file in question does not have the ReadOnly ATTRIBute set.

---- Original Message ----
From:		David Corbin
Date:		Fri 4/13/01 10:06
To:		ant-user@jakarta.apache.org
Subject:	Re: Delete fails...

In the junit subdir, I have a build.xml, and a junit3.5.zip, both of
which are in source control.  During the build, the zip file gets
unzipped creating a junit3.5 subdirectory, and all of it's contents. 
The file in question is created by the unzip.

As for rebooting, I can't say that I remember specifically trying, but I
certain will give it a go (I've been using Linux so much, rebooting just
doesn't come to mind:) Now that I'm having to work with "that other OS",
I guess I'll have to re-remember to reboot every two hours :))

Diane Holt wrote:
> 
> --- David Corbin <dcorbin@imperitek.com> wrote:
> > I tried that, and I tried NTHandle | grep junit.
> >
> > Nothing is holding the file open.
> >
> > It *seems* like that cygwin rm also fails (silently) to delete it, but
> > DEL frequently (if not always) succeeds.
> >
> > More ideas?
> 
> I take it you've tried rebooting? :)
>   
> When/how does the file get created as part of the build process? Is it
> pulled from an SCM tool that marks it read-only?
> 
> Diane
> 
> =====
> (holtdl@yahoo.com)
> 
> __________________________________________________
> Do You Yahoo!?
> Get email at your own domain with Yahoo! Mail.
> http://personal.mail.yahoo.com/

-- 
David Corbin 		
dcorbin@imperitek.com



Mime
View raw message