ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephane Bailliez <sbaill...@imediation.com>
Subject RE: JUnitReport
Date Thu, 19 Apr 2001 08:32:44 GMT
1) xalan1 compatibility jar from xalan2 will not work, documentation is
misleading. Sorry about that. Unfortunately it was not compiled with this
compatibility jar.
 
2) ant is shipped with jaxp.jar and parser.jar for convenience since it is a
small parser, most of the time you'd better replace it with the parser you
use. It just have to be jaxp compliant which is the case of xerces. It
should work fine with xerces 1.2.2, 1.2.3 and 1.3.0
 
Hope it helps.
-- 
 St├ęphane Bailliez 
 Software Engineer, Paris - France 
 iMediation - http://www.imediation.com <http://www.imediation.com/>  
 Disclaimer: All the opinions expressed above are mine and not those from my
company. 

-----Original Message-----
From: Paul Dillon [mailto:paul.dillon@solnet.com.au]
Sent: Thursday, April 19, 2001 8:12 AM
To: ant-user@jakarta.apache.org
Subject: JUnitReport


JUnitReport isn't working for me either - I'm also getting this error:
 
XSL Error: Cannot use a DTMLiaison for a input DOM node... pass a
org.apache.xalan.xpath.xdom.XercesLiaison instead!
 
I've tried a whole bunch of things, including xalan1 compat jar from xalan2,
and xalan1.2.2.  I've verified that there are no other XML parsers in my
classpath except xerxes, although it looks like ant comes with Sun's XML
parser extension.
 
What is the known working configuration for JUnitReport?
 
Thanks,
 
Paul


Mime
View raw message