ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Champeau <schamp...@leaselink.com>
Subject Strange Compile Behavior in 1.3
Date Fri, 06 Apr 2001 00:43:06 GMT
I have been using Ant 1.2 to build our project now for several months with
great success. When I tried to use 1.3, I ran into a problem. When I try to
compile the project, it errors out on a class that uses the Xerces 1.3.0
method:

org.w3c.dom.Document.createElementNS(String, String)

with the error

"Method createElementNS(java.lang.String, java.lang.String) not found in
interface org.w3c.dom.Document."

This behavior is absolutely consistent, producing the same result multiple
times on several different workstations. This class builds fine with Ant 1.2
under the exact same configuration (classpath, etc.), and it works using
javac directly from the command line. If there was a fundamental problem
with the version or location of my Xerces jar, I would expect to see many
more errors.

Does anyone have any idea what could be going on here?

Thanks,

Steve C.






Mime
View raw message