ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Peterson, Lance" <lpeter...@verticore.com>
Subject RE: Reposted: Re: FileSet
Date Wed, 18 Apr 2001 15:37:05 GMT
Francisco, I'm fairly new to Ant myself and until now I've never used the
Javadoc task.  But I'm seeing the same behavior.  The Javadoc task's
sourcefiles attrib doesn't seem to accept regular expressions or wildcards.

This is odd.  The Ant user guide says it's a much better practice to include
everything inside the build.xml file using the sourcefiles attrib.  But for
my projects, "everything" means hundreds of files!  I really prefer
build.xml to be as compact as possible.  And I really don't like having to
revise build.xml every time I add a new class to my project.

Does anyone know of a ready alternative?

-----Original Message-----
From: Francisco Franco [mailto:francisco@powermarket.com]
Sent: Thursday, April 12, 2001 6:51 PM
To: 'ant-user@jakarta.apache.org'
Subject: Re:FileSet 


I need to pass several source files to javadoc's sourcefile directive by
using a regular expression.  I get the following error for the xml code:

<javadoc packagenames="com.powermarket.*"
	       docletpath="c:/cygwin/home/ffranco/ejben/ejbgen.jar"
	       doclet="EJBGen"
	       sourcepath="${main.dir}"
	       sourcefiles="**/*Bean.java"/>

[javadoc] Javadoc: No package, class, or source file found named
**/*Bean.java

[javadoc] 1 error

I want to get away from using [package name]/*Bean.java for each
level of my source tree that I want to run the javadoc command on.  I know
that this regular expression works for filesets in which a desired pattern
can be obtained from muliple directory levels using **.  However, I don't
know how to pass these file names into javadoc's sourcefile directive by
using the fileset directive. I tried using ids but apparently, javadoc's
sourcefile attribute does not support the refid command.  Any suggestions
and/or examples?

Thanks,
Francisco 


-----Original Message-----
From: Diane Holt [mailto:holtdl@yahoo.com]
Sent: Thursday, April 12, 2001 5:35 PM
To: ant-user@jakarta.apache.org
Subject: Re: Delete fails...


--- David Corbin <dcorbin@imperitek.com> wrote:
> I tried that, and I tried NTHandle | grep junit.
> 
> Nothing is holding the file open.
> 
> It *seems* like that cygwin rm also fails (silently) to delete it, but
> DEL frequently (if not always) succeeds.
> 
> More ideas?

I take it you've tried rebooting? :)

When/how does the file get created as part of the build process? Is it
pulled from an SCM tool that marks it read-only?

Diane

=====
(holtdl@yahoo.com)



__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

Mime
View raw message