ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pinar Bicioglu <p.bicio...@CustomerDialogue.com>
Subject Using different JDK
Date Thu, 26 Apr 2001 14:24:34 GMT

I have written the code below in order to use jdk1.2 for the target
"asi-compile". It works fine. But I have no evidence that it's using jdk1.2.
Do you think it would work correctly

Thanks a lot

<target name="asi-compile" depends="default">
  <antcall target="default">
      	<param name="build.compiler" value="classic" />
  </antcall>
  </target>

  <target name="default" depends="prepare">
         <echo message="build.compiler=${build.compiler}"/>  
         <javac srcdir="${src-dir}" 
                destdir="${build-dir}" 
                classpath="${classpath}" 
                deprecation="on" 
                optimize="off" 
                includes="${asi-compile-list}" 
                excludes="**/lite*.java,**/Lite*.java" />    

Mime
View raw message