ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pinar Bicioglu <p.bicio...@CustomerDialogue.com>
Subject RE: pulling out the code from SourceSafe
Date Tue, 17 Apr 2001 18:13:49 GMT
I believe, fixing this is pretty simple. And the solution is just in front
of my eyes! But I can't see it right now. :) Isn't that the worst part about
debuging :)

Thanks for your all help!

-----Original Message-----
From: Kevin Cummings [mailto:kevin.cummings@mongoosetech.com]
Sent: Tuesday, April 17, 2001 2:11 PM
To: ant-user@jakarta.apache.org
Subject: RE: pulling out the code from SourceSafe


That is truly weird!! I'm sorry but I have no idea what would cause this to 
happen or how you might go about fixing it.. Unless the directory is 
getting changed by the build process and then the next time you try to run 
it you are in the wrong directory. That is just a guess though..

At 01:56 PM 4/17/2001 -0400, you wrote:
>yes! definetely this is what happens...I've tried so many times and
>everytime I got the same results!
>
>-----Original Message-----
>From: Kevin Cummings [mailto:kevin.cummings@mongoosetech.com]
>Sent: Tuesday, April 17, 2001 2:00 PM
>To: ant-user@jakarta.apache.org
>Subject: RE: pulling out the code from SourceSafe
>
>
>You mean if you try to run the target twice in a row it tells you that it
>doesn't exist?? That's really strange!! Are you sure you typed it
>correctly? I'm at a loss here if you are just typing the same command twice
>and it works once and then not the next time.. Try it again and see if you
>get the same results.
>
>At 01:42 PM 4/17/2001 -0400, you wrote:
> >Kevin and you were both right! I have a target called asi but it depends
> >on "asi-compile" which is the executable part!
> >
> >I have one more and hopefully last question! so "ant getcode" is working
> >now. But right after writing "ant getcode", if I try to execute it again
> >by writing the same command ("ant getcode"), it says "Target `getcode'
> >does not exist in this project."
> >Is it what it is suppose to say? I mean it is logical to get the code
once
> >instead of getting it everytime when i run build.xml
> >-----Original Message-----
> >From: Peterson, Lance [mailto:lpeterson@verticore.com]
> >Sent: Tuesday, April 17, 2001 1:32 PM
> >To: 'ant-user@jakarta.apache.org'
> >Subject: RE: pulling out the code from SourceSafe
> >
> >Pinar, this is what you put in your original post about the getcode
target
> >failing...
> >
> ><target name="getcode">
> >         <echo message="getting latest code from the Source Safe..."/>
> >  <vssget vsspath="/assetplanner/Engineering/dev/java"
> >          login="pbicioglu, pinar"
> >   writable="true"
> >   localpath="D:/sandbox/Engineering/dev/java"
> >   recursive="true"
> >   ssdir="D:\ProgramFiles\MicrosoftVisualStudio\VSS\win32" />
> >   </target>
> >
> > From this it looks like the value for ssdir doesn't have any
> > spaces.  Please verify that your build.xml has the correct path for
> > SS.EXE.  Please note that by default SourceSafe 6.0 installs to \Program
> > Files\Microsoft Visual Studio\Common\VSS\Win32 (note the "Common").
> >Regarding your getcode-compile issue, the syntax for running Ant is...
> >
> >ant [options] [target [target2 [target3] ...]]
> >
> >I've never heard of being able to specify "target-compile" instead of
> >"target".  If I have the following build.xml file...
> ><?xml version="1.0"?>
> ><project name="testing">
> >   <target name="test1">
> >     <echo message="Test #1"/>
> >   </target>
> >   <target name="test2">
> >     <echo message="Test #2"/>
> >   </target>
> ></project>
> >
> >...and I want to run both tests, I'd execute the following:
> >
> >ant test1 test2
> >
> >This tells ant to execute the targets named "test1" and "test2".  When I
> >try to execute "ant test1-compile test2-compile" ant tells me
> >"test1-compile" doesn't exist, which is correct.  Are you sure you don't
> >have a target named "asi-compile" instead of "asi"?
> >Best regards,
> >Lance Peterson

Mime
View raw message