ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Corbin <dcor...@imperitek.com>
Subject Re: Delete fails...
Date Thu, 12 Apr 2001 20:09:20 GMT
Your idea makes sense, but that's not it...

Brian Murray wrote:
> 
> Could be a couple of simple causes which I've discovered by beating my head
> against a wall:
> 1. Command prompt window open with the current directory == ${archive} (or
> one of its subdirs)
> 2. Windows explorer open and the currently selected folder == ${archive}
> 
> Point 2 doesn't seem to happen consistently, but it does happen to me
> occasionally.
> 
> ----- Original Message -----
> From: <dcorbin@machturtle.com>
> To: <ant-user@jakarta.apache.org>
> Sent: Wednesday, April 11, 2001 11:30 AM
> Subject: Delete fails...
> 
> > I've the following ANT script:
> >
> > <project name="Junit install" default="install" basedir=".">
> >         <property name="archive" value="junit3.5"/>
> >         <property name="archivetype" value="zip"/>
> >
> >         <target name="prepare">
> >                 <available file="is.installed" property="is.installed" />
> >         </target>
> >
> >         <target name="install" depends="prepare" unless="is.installed">
> >                 <unzip src="${archive}.${archivetype}" dest="."/>
> >                 <touch file="is.installed" />
> >         </target>
> >
> >         <target name="clean">
> >                 <delete dir="${archive}"/>
> >                 <delete file="is.installed"/>
> >         </target>
> > </project>
> >
> >
> > I'm getting the following result:
> >
> > Buildfile: build.xml
> >
> > clean:
> >    [delete] Deleting directory
> C:\data\Source\CMS\ThirdParty\junit\junit3.5
> >
> > BUILD FAILED
> >
> > C:\data\Source\CMS\ThirdParty\junit\build.xml:15: Unable to delete file
> > C:\data\Source\CMS\ThirdParty\junit\junit3.5\junit.jar
> >
> >
> > ATTRIB shows that the file is not readonly:
> > C:\data\Source\CMS\ThirdParty\junit>attrib junit3.5\*
> >            C:\data\Source\CMS\ThirdParty\junit\junit3.5\junit.jar
> > A          C:\data\Source\CMS\ThirdParty\junit\junit3.5\README.html
> > A          C:\data\Source\CMS\ThirdParty\junit\junit3.5\src.jar
> >
> > This seems to work fine on Linux, and fail on Windows 2000.  Any ideas?
> >
> >

-- 
David Corbin 		
dcorbin@imperitek.com

Mime
View raw message