ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Magnus Rosenquist,,," <magnus.rosenqu...@mobilemind.se>
Subject Exec problems
Date Tue, 10 Apr 2001 07:40:52 GMT
Hi folks,

I have some problems with the exec tag,
I have successfully used it with native commands
such as 'ls', 'mkdir' etc... But when it comes
to me using a shell-script this fails.

The tag looks like this:

<target name="ejb">
    <exec executable="/usr/local/bin/copy.sh" os="Linux">
      <arg value="1"/>
      <arg value="2"/>
    </exec>
</target>

When I run ant with ejb as the target I get the following
message:
---------------------------------------------------------
Buildfile: build.xml

ejb:
      [exec] Result: 255

BUILD SUCCESSFUL

Total time: 3 seconds
---------------------------------------------------------

The result is '255' and the script is never executed,
the script just echoes the arguments to a file.

Above the full path to the script is defined, I have
also tried with adding the script to my PATH but with
the same problem...The script is executable and runs
perfectly from the prompt.

Does anybody have any ideas what this might mean and
a way around it?

regards,
/Magnus

-- 
___________________________________
Magnus Rosenquist
Mobile Mind AB
+46 (0)63 57 48 88     (Phone)
+46 (0)702 69 41 72    (Mobile)
mailto:magnus.rosenquist@mobilemind.se
http://www.mobilemind.se


Mime
View raw message