ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jaideep satghare <jaideep_...@yahoo.co.in>
Subject Problem with iasdeploy using ANT 1.2
Date Wed, 25 Apr 2001 05:15:09 GMT
Hi all,

I am using the Ant 1.2 tool to deploy J2EE
applications in the Iplanet application Server 6.0
SP2.
We have a commandline utility to do this, called
iasdeploy which has the following syntax.

C:\>iasdeploy deployapp -help
iasdeploy for iPlanet Application Server 6.0 SP2
Displaying help for command: deployapp
Usage: iasdeploy deployapp [-verbose] [-instance
<instance>...|
 -user <username> -password <password>] [-host <host>
-port <port>]]]
<EAR file>

Where:
<EAR file> -file name of the J2EE application EAR file
to deploy.

I have used this utility in the following way


<project name="CSW" default="deploy" basedir=".">

<property name="CSW_EAR" value="CSW.ear" />
<property name="USER_ID" value="admin" />
<property name="PASSWD" value="admin" />
<property name="IP" value="155.39.173.246" />
<property name="KAS_PORT" value="10817" />

<target name="deploy">

<echo message="Executing Step , deploying the CSW.ear
file." />
<echo message="Please wait..." />
<!-- Running the iasdeploy utility to deploy the
CSW.ear    -->
<exec dir="." 
         executable="iasdeploy">
<arg line="deployapp -user ${USER_ID} -password
${PASSWD} -host ${IP} -port ${KAS_PORT} ${CSW_EAR}" />
</exec>

<echo message="Done." />      
</target>

</project>


But I keep getting the following error message without
any clues. Just an "error=2" message is displayed.


C:\jaideep\ant\changes due to sp2\deploytest.xml:18:
Execute failed: java.io.IOException: CreateProc
ess: iasdeploy deployapp -user admin -password admin
-host 155.39.173.246 -port 10817 CSW.ear  error
=2
java.io.IOException: CreateProcess: iasdeploy
deployapp -user admin -password admin -host 155.39.173
.246 -port 10817 CSW.ear  error=2
        at java.lang.Win32Process.create(Native
Method)
        at
java.lang.Win32Process.<init>(Win32Process.java:64)
        at java.lang.Runtime.execInternal(Native
Method)
        at java.lang.Runtime.exec(Runtime.java:272)
        at
org.apache.tools.ant.taskdefs.Execute$CommandLauncher.exec(Execute.java:325)
        at
org.apache.tools.ant.taskdefs.Execute$CommandLauncherProxy.exec(Execute.java:431)
        at
org.apache.tools.ant.taskdefs.Execute$WinNTCommandLauncher.exec(Execute.java:456)
        at
org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:247)
        at
org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:213)
        at
org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:154)
        at
org.apache.tools.ant.Target.execute(Target.java:142)
        at
org.apache.tools.ant.Project.runTarget(Project.java:818)
        at
org.apache.tools.ant.Project.executeTarget(Project.java:532)
        at
org.apache.tools.ant.Project.executeTargets(Project.java:506)
        at
org.apache.tools.ant.Main.runBuild(Main.java:420)
        at
org.apache.tools.ant.Main.main(Main.java:149)


Has anyone encountered similar behaviour or have any
clues on this.

Thanks,
Jaideep.


____________________________________________________________
Do You Yahoo!?
For regular News updates go to http://in.news.yahoo.com

Mime
View raw message