ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject Re: <wlrun>, finding the confi.xml file
Date Mon, 30 Apr 2001 13:29:16 GMT
----- Original Message -----
From: "Les Hughes" <leslie.hughes@rubus.com>
To: <ant-user@jakarta.apache.org>
Sent: Monday, April 30, 2001 9:07 PM
Subject: RE: <wlrun>, finding the confi.xml file


>
> Conor / Simon,
>
> Yes, everything's fine outside of Ant. The pre-patched download of 6.0sp1
> doesn't have weblogic_sp.jar - it's all rolled into weblogic.jar I think.
>

I think the weblogic_sp.jar is just a bit of future-proofing allowing
service packs to be dropped in in future without changing configs. The
current contents of the jar are minimal (version class and manifest). So,
it is a good idea to include it in your setup but currently won;t affect
things.

> My fault anyway, I have two projects deployed on my box  - d:\weblogic is
a
> 5.1 tree....Doh! The 6.0sp1 server is starting just fine - except...
>
>  * java.lang.UnsatisfiedLinkError: no wlntio in java.library.path

I have the weblogic bin directory in my path so that the native I/O DLL can
be picked up

>  * the forked process doesn't invoke -hotspot nor can you pass -Xmx
and -Xms
> args

You can use jvmargs attribute to pass -Xmx etc. I haven't tried -hotspot.

>  * Does Ant still block whilst wls is active? I though I saw a patch go
in
> to fix this....

Yes it does. I have been reluctant to apply spot solutions to this problem
(exec, wlrun, etc) since I think a more general solution to multithreading
is appropriate.

>
> BTW I'm writing an article for DrDobbs on WLS6.0 Ant and SCM (Perforce
since
> this is what we use here) Either of you two guys (or anyone else)
interested
> in adding some thoughts, input etc. Mail me offlist if you are.
>
> Bye,
>

Conor


Mime
View raw message