ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Problem with Java 1.3 on AIX 4.3.3
Date Mon, 05 Mar 2001 07:51:43 GMT
Scott,

could you please run a build file with a 

<echo message="${java.class.path}" />

task? tools.jar of your JDK 1.3 should be included and *no* tools.jar
or classes.zip of _any other_ JDK. Is this the case?

Next, the code that falls back from "modern" to "classic" when
"modern" cannot be found has been introduced by me. Prior to that Ant
would have invoked the modern compiler when running in an 1.3 JVM or
fail if it couldn't do so. The reason why I implemented the fallback
was, that Ant failed to load the modern compiler in a pre-release of
IBM's JDK 1.3 for Linux. Sounds familiar?

But before we blame it on the JDK, lets search for problems in your
setup or Ant itself.

Stefan

Mime
View raw message