ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: mysterious error: "Cannot use classic compiler, as it is not
Date Fri, 09 Mar 2001 07:07:19 GMT
Mark Johnson <markj@gilanet.com> wrote:

> The only similar problem I can find in the archives seems to occur
> when there is no PATH to javac. However, my PATH includes
> $JAVA_HOME/bin, where javac resides. Eg,

You don't need javac in your PATH, but you need tools.jar in your
CLASSPATH. Usually Ant determines the location of it from JAVA_HOME
and adds it automatically, but something seems to be going wrong here.

Two things you could try

(1) Create a buildfile that does nothing but 

<echo message="${java.class.path}" />

Look whether tools.jar is in there - and try to find out, why it
isn't. 8-)

(2) Install Ant 1.3. You didn't say, which version of Ant you are
using, maybe you've been bitten by a bug that has been fixed since the
release of Tomcat 3.1?

Stefan

Mime
View raw message