ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Kozlowski <>
Subject Re: "Cannot use classic compiler, as it is not available" problem
Date Fri, 02 Mar 2001 15:32:10 GMT
On 2 Mar 2001, Stefan Bodewig wrote:

> It doesn't look as if your CLASSPATH definition from above gets passed
> to Ant, otherwise tools.jar would be included in this -classpath
> argument for the javac task as well.
> Could you add an <echo message="${java.class.path}" /> somewhere to
> see which CLASSPATH Ant has been invoked with?

I've managed to solve the problem:  While I was trying various things to
get it to work, I ran ant with the -debug flag, and noticed things that
looked odd in the properties that are displayed; sure enough, it turns out
that what I thought was a straight-up JDK 1.2.2 turned out to be a
"release candidate" from  After installing the official Sun
JDK, the problems went away.

My thanks for the help.

Mike Kozlowski

View raw message