ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ouellet...@foliofn.com (Timothy Ouellette)
Subject embedded ant calls not executing properly
Date Thu, 29 Mar 2001 14:15:23 GMT
I apologize if you received this yesterday however my subscription to the
list was not complete

I have a problem where the ddcreator fails when I reference the sub-project
build.xml from the master as shown below.  If I run the subproject build.xml
from the commandline without going through the master build.xml file it
works fine.  Any ideas on why this might be?

I'm running Ant 1.3 on Solaris 5.6.

Attached is a snipette from the master and a copy of the child.

-Tim

master build.xml
<!-- DEPLOY -->
<target name="deploy" >
   <ant dir="./source/com/foliotrade/tradeapp/ejb/entity/impl"
target="deploy" />
</target>


package level build.xml
<project name="subproject" default="deploy" basedir=".">

<!-- Setup Init -->
<target name="init">
  <tstamp/>
  <property name="env" environment="myenv" />
  <property name="Src" value="." />
  <property name="Dest"
value="${myenv.FOLIOHOME}/projects/v1/tradeapp/classes" />
</target>

<!-- BUILD -->
  <target name="build" depends="init">
    <javac srcdir="${Src}" destdir="${Dest}" classpath="${myenv.CLASSPATH}">
      <include name="*.java"/>
    </javac>

  </target>

<!-- DEPLOY -->
  <target name="deploy" depends="build">
    <ddcreator descriptors="${Src}" dest="${Dest}">
      <include name="*DeploymentDescriptor.txt" />
    </ddcreator>
    <ejbc descriptors="${Dest}"
        src="${Src}"
        dest="${Dest}"
        manifest="deployment.manifest">
      <include name="*.ser" />
    </ejbc>
  </target>
</project>


Mime
View raw message