ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ventimiglia, David" <David.Ventimig...@msdw.com>
Subject RE: JUnitReport classpath problem
Date Thu, 22 Mar 2001 17:06:25 GMT
Thanks, Conor.  I actually got it to work (sort of) by using the latest
stable release of Ant 1.3.  I guess my questions in general are these.  When
using <junitreport>, what XML parser should I use (parser.jar or
xerces.jar)?  If <junitreport> requires xerces.jar, and since it's a
"built-in" task and not even an "optional" task, would it make sense to
replace parser.jar with xerces.jar as the default parser that ships with the
Ant distribution?

Thanks!
Cheers,
David

-----Original Message-----
From: Conor MacNeill [mailto:conor@cortexebusiness.com.au]
Sent: Wednesday, March 21, 2001 10:02 PM
To: ant-user@jakarta.apache.org
Subject: RE: JUnitReport classpath problem


David,

I think there would be a benefit in trying out the 1.3 release code and then
coming back yto us if you still have problems. There were certainly some
changes in this task during the various betas and it would be good if we are
all starting from the same point.

Conor


> -----Original Message-----
> From: Ventimiglia, David [mailto:David.Ventimiglia@msdw.com]
> Sent: Thursday, 22 March 2001 9:06 AM
> To: Ant-User (E-mail)
> Subject: JUnitReport classpath problem
>
>
> Hi,
>
> When I use the <junitreport> task, I get a 'NoClassDefFoundError'
> exception
> thrown because it can't find org/xml/sax/ext/LexicalHandler.  I
> noticed that
> this class is in the Xerces XML parser, but the Ant manual doesn't mention
> the need for Xerces, only for Xalan.  When I add xerces1_2_1.jar to my
> CLASSPATH environment variable, I get this error:
>
> XSL Error: Cannot use a DTMLiaison for a input DOM node... pass a
> org.apache.xalan.xpath.xdom.XercesLiaison instead
>
> Some messages in this list's archive indicated incompatibilities
> between the
> Xerces parser and the parser that ships with Ant.  At least one message
> recommended removing or renaming parser.jar and jaxp.jar, but
> without those
> Ant itself won't work.  How is this supposed to be resolved?
>
> I'm running a beta version of Ant 1.3:
>
> Ant version 1.3beta1 compiled on February 6 2001
>
> Thanks,
> David
>

Mime
View raw message